Nested forms - "New button missing"

I have tried and tried, but for some reason my nested forms just won’t show a new button. It will only let me view and edit existing child records but not add new ones. Can someone help me on this please? Is this a bug?

Hello @Enrich_Lives_Foundat, here’s a few things you can check to find your missing button:

  • Does the table or slice allow adds?
  • Is the user allowed to make adds to that table? (in case you have an user system)
  • Is the action for adding a row to the child table visible?
3 Likes

Hi Rafael, i’m using a slice and it does infact allow for new “add” rows. Not using a user system. The button / link “New” to add new child rows is not visible at all - i’ve tried innumerous times. Could you please help clarify?

I meant the action configuration itself, in the “Prominence” settings, see here:

Does the table you’re slicing from also allow adds?

2 Likes

Yes the table being sliced also allows for “add”.
You were correct, the system generated “Add” action was tagged to “do not display” and hence the error. Thank you so much for helping out - i’ve been struggling with this forever. This is very helpful! Thank you!

4 Likes