New Bug Encountered: AUTO Changing column types

Just wasted 15mins debugging a dependant drop down. The issue was the column type had change AUTOMATICALLY from Text to Number. Despite the data it was pulling in was clearly text only

I’ve had this happen numerous times now over the past few weeks. I go into a column to edit something, come out, then notice the type has changed. Never used to do this

There are bug reports going back to at least March reporting this

Apart from when you add an entirely new table or regenerate a new column in, I see no reason for Appsheet to change column types itself

3 Likes

I too would like to see this fixed. I’ve written about it more than once in the past. Here’s the latest post I could find:

3 Likes

@Aleksi this is happening to me again. Was this ever fixed?

Perhaps this is why things have started getting weird in apps; things that once worked now don’t. Column types are changing.

It happens when I save the expression builder; like when you’re first building a virtual column - the system analyzes your formula and guesses the column type - except it’s doing it on physical columns that have been there forever.

#NotAFan

5 Likes

It would be nice to be able to disable any function that might automatically change the column type.

4 Likes

@MultiTech_Visions Would you please send this to supprt@appsheet.com so we could investigate it directly from your app, thanks.

2 Likes

Just got through with an email string from support: This is intended behavior and will continue to operate this way.

I had always thought about the auto-column-type setting thing along the same lines as the initial value formula space we have in appsheet apps; it’s evaluated when things are first created, but once it’s saved its set - and if you manually change it then it’s 100% manual from then on.

This was incorrect.

Anytime you save the app formula, not sure about initial value, appsheet will reevaluate what column type it thinks the column should be based on your formula.

Lock down your formulas with type-converters (DATE(), TEXT(), etc.)

In my case here, I have a long conditional branching IF() statement that pulls in data from different parts of the app based on certain criteria; one of these is a decimal type, and since I didn’t wrap that part in TEXT() or CONCATENATE() the system picked up the decimal and set the type to that - I need the column to be text for display purposes.

Wrapping TEXT() around the [Decimal_Column] part worked, because now all the branches of my IF() statements are all the same type: text.

7 Likes

This is very useful information, thanks for the heads up.

1 Like

Note that TEXT() may reformat its input, so better to use CONCATENATE().

2 Likes

All good to know for future.

Hi @MultiTech_Visions!

Thanks a lot! If you have time, it would be great if you could post the same information (adding @Steve’s point) in the “Tips & Tricks” category. I think that more people will see it there, particularly as time passes. In terms of content, it definitely fits the category. :slight_smile: Great tip!!

2 Likes

I had múltiple columns with the same example that you mention.
I had thouse in virtual, and it always give me trouble.
Try to do it in non virtual, that solves part of the issue.
The IFS should get the data from non
Virtual columns, if virtuals are are the columns with complex calculation may be you will have some trouble when data row is updated.