New Bug Encountered: Column App formula working in Editor but not in real App

After applying this expression, the entire application is running smoothly in editor mode testing but in real App, it’s giving an error like “completed By is required” It’s already given in App formula.

I also placed the static string “ABCD” in-app formula but it’s working fine in editor App testing and Real Application gives the same error.

Any suggestions would be great. Thanks :slight_smile:

Default_Settings[User] is a column reference and produces a list of all values in the User column of the Default_Settings table. Is that your intention?

I tried ANY(Default_Settings[User])but it also not working. At last, I placed the static string “ABCD” in App formula and it works fine as expected but the Real app still gives the same error. I Re-installed the app again but the same error.

Had you saved the app formula with "ABCD" and synced the app?

Please post a screenshot of the error in the app.

@Steve Yes, I saved and synced multiple times. I am very surprised that I did not change any code since last week and it suddenly started giving an error.

image

Is there an action or workflow involved?

Is the Default_Settings a slice? If so, what is the filter expression?

Yes, One Action is involved but it only set the column values of that particular Row. Nothing related to Completed By column and I also make required off for “Completed By” column but still getting the same error. The strange thing this error has “Completed by” and my column name is “Completed By”. it has small b

The same code was working last week. I am started getting error from yesterday.

The behavior you’re seeing does seem very odd to me and I can’t see what might be causing it. I have to recommend you engage support@appsheet.com directly for help on this.

Thanks @Steve fro your help. Let me drop an email to the support team.

1 Like