New Bug Encountered: data doesn't write to sheet and formula doesn't save

Hey hey

I’ve been trying to make a few changes to my app these past couple of days and it seems a few bugs have crept in

  1. Yesterday I tried to enter a data constraint into a field but kept getting an error. however, after syncing 3-4 times it allowed me to save the formula that I knew was correct. SOLVED.
  2. Today, I’m trying to save a key column formula as UNIQUEID() but it simply doesnt save. I update the formula, hit save, the editor reloads, but nothing is saved. I’ve tried 5+ times now and still nothing
  3. Second column in the same table has a reference to a parent table. When I enter a new row in the app using the form, the ref to the parent ID is visible but not editable as it should be. But when I save the entry, this particular column doesn’t write onto the sheet. I checked google sheet versions - no errors - and the audit log - also no errors.

Pls fix these annoying small sync errors

Thanks!

Olivia

Hi,

  1. Solved. Could have been an internet connection or browser issue.
  2. Is this column set as a text type? For example if it is set a number then it would not work. Is the column set as editable? If not, it will not be able to fill in anything. You also might get a clue from the info tab. After you put in UNIQUEID() and then save and it disappears, you will probably have a yellow circle beside info. That can give a clue as to why it removed your UNIQUIEID() formula.
  3. Is this column set to be a part of the other table? That will solve the writing issue. For the columns that show up, you will need to edit which columns are visible on that table. Go to the referenced table columns and set which values should be visible and editable.

None of these seem like sync errors.

Hey - thanks for fast reply

  1. Likely
  2. yes it’s a text type and editable. No warning on info tab
  3. yes it is part of the parent table. FYI I have an exactly identical third column to another parent table on the table that writes just fine to the sheet

Olivia

For troubleshooting (1), it would have been helpful to know the error message you got.

For (2) and (3), what are the names of the columns involved?

Is there any chance your network traffic is being filtered?

on (1) it said that it couldn’t find [_THIS] column. But it’s not a column, its referring to the entered value in the field that I was creating the valid_if constraint for

The key is called [Request ID] and the column that doesn’t write is [Asset ID]. Table is called Transfer Requests. The column I’m trying to refer to is also called on [Asset ID] on the Asset table…

I’m not sure about network traffic… I work in Rwanda where the internet in general has certain restrictions but I don’t think the network in our office has any special restrictions or filtering. How would I find out?

I saw someone post yesterday that _THIS was not recognized by Expression Assistant when composing a Valid If expression, so unless that post yesterday was from you, at least one other person also noticed this problem. But, as you’ve seen, it was transient.

You’d need to get your IT folks involved, but even that may not be enough depending on what filtering might be occurring.

Filtering probably isn’t the problem, but the idea did jump to mind as I read your post.

probably was me - I wrote the post but then deleted it when it worked after some 20 minutes

1 Like

In the app editor, click on Manage along the left side, then go to the Versions tab, and expand Version History. Here is recorded each save you make from the app editor. If you click the Expand button for a particular saved version, the changes in that version are described (cryptically, but described nonetheless).

Try making your change again (only that one change!), save it, then check whether the change is captured in the version history. Take note that versions saved within the last minute may not show immediately.

I just waited some 10 minutes and the change still doesn’t show up in the version history…

That is very odd. Please reach out to support@appsheet.com. That team is probably in a better position to help than I.

1 Like

And for this issue?

I suspect both issues might be due to a deeper problem in your app definition. The support team is better equipped to help you troubleshoot further.

1 Like

ok so with the help of the support team I managed to find solutions to both “bugs” which turned out to be just minor issues on my part…

  1. Fixed by using the UNIQUEID() as an initial value - it’s not a formula but a value so it should go here
  2. The column has to be editable - I had unticked the editable box to prevent accidental changes but I guess we’ll have to live with this

thanks!

Awesome!

You can fix this: set the Editable? property to the expression, FALSE, instead of setting it to OFF. Confusing, but it works. Why? Because Editable? is a misnomer. When you choose ON or OFF, you’re actually choosing whether the column is read/write (ON) or read-only (OFF) for the entire app. When you set an expression, the column is made read/write for the app, but the user’s access is controlled by the expression. This then gives you the ability to prevent the user from editing a visible column value in a form, while still being able to use actions to modify the value.

1 Like