New Bug Encountered: Editing a copied Workflow changes the original and vice-versa

I consider this a moderately serious bug.

When I create a copy of a Workflow to send an Email, changing any of the critical criteria parameters such as Email Subject, Email Body, PreHeader, Attachment Name and EVEN THE ATTACHMENT TEMPLATE, causes changes in the original workflow. AND VICE-VERSA - changing the original causes those changes to be applied into the copy.

I do not know if other copied workflows are also impacted.

It’s as if the two are linked - (i.e. referencing the same in memory object).

I can create a NEW workflow and insert the same details and all is well.

This is a problematic blow to those apps that need to create a series of similar email workflows. Having to create a NEW workflow and then copy/paste the details is excruciatingly painful and time consuming.

Sending to AppSheet support as well.

3 Likes

AppSheet support has looked at this and is not seeing the issue. I am wondering if anyone else is actually experience this issue?

I have tried all manners of clearing cache and refreshing to try to remove this behavior. I have tried:

  1. Closing app and re-opening.
  2. Logging out an back in to AppSheet
  3. Clearing the Google cache.
  4. Restarting the computer
  5. Accessing AppSheet from Incognito mode

The same problem persists.

Additionally, I have confirmed that this problem occurs in multiple apps AND for other types of Workflows.

Here is a link to a video I created for AppSheet demonstrating the issue. Maybe it will help someone else understand the problem.

1 Like

John,

I cannot reproduce it today but that certainly seems to explain the trouble I was having yesterday when I copied the workflow and pieces kept messing up.

In your video, I didn’t notice you saving after copying the workflow. Does that make a difference? If you save as soon as you copy it.

Lucinda