New Bug Encountered: Enum error

Hello

I’m having an error when every time I use an enum list for Appsheets and I want to update my app with will display Value “XXX”" in field XXX cannot be converted to type Enum but previously I had no problems with the enum listing before

I have tried with and with out Allow other values, and Auto-complete other users
I have also tried changing the enum listing to a text and ref with a sheet to refer to it and I still get the same error but with a different first value.

Any suggestions would be appreciated.

What exactly are you trying to do?

What exactly is the error?

Do you have any expression in valid_if?

2 Likes

Hi Marc,

So this is a might be a little complicated so I have this function to people clock in and out for their work (This part works and will update my other sheet that are needed)

As soon as I clock out the refresh button will have 2 notification for sync that will display this error when trying to sync

image

and this is the error when trying to sync

This is the view when hitting the clock in which is referring to the type of work.

Why are there 2? How is this functionality being used? An Action? a Form? Is there a Form Saved Behavior running on a Form?

The error indicates that the literal value “Type of Work” is trying to be saved in the column of the same name, any idea why that is?

2 Likes

I think I figured it out

image

That had to be changed

Thanks again for your help

3 Likes