New Bug Encountered: Error in "App: Goto another view within this App"

This was working 15mins ago and with no changes now isn’t

I have a table called Data, with an Action called “Add User”. This does a “App: Goto another view within this App”. The view its pointing to is called “Add New Customer Form”. This is a form view to create a new record in the Customer table.

When I click on the action, the App trys to sync then fails with"

The Add New Customer Form app did not load successfully. Please contact the app creator.
Unable to fetch app definition. App ‘Add New Customer Form’ was not found.

Changing it to point at the System view “Customer Form” fails the same way

I have the “Add New Customer Form” view in the menu section and it works fine

To me the error message implies that its trying to look for another App and not another view :confused:

What is the expression?

There isn’t one. Its simply an action pointing at a view

Just added another action to a different view and got same error :frowning:

I’ve never thought to try just entering a view name as the target of that action; I’ve always used a deep link expression. Have you tried a deep link?

Hi @Steve

Changing it to LINKTOVIEW() works fine. But it DID work before for about an hour with just the view name, and nothing has been changed.

Today seems to be a strange day. Lots of stuff working, then stopping. Or expressions which don’t work, but start doing so when you chopped them up and testing each bit in detail. :open_mouth: Also the server has been offline at least once and generally very slow (5-10 secs to update a slice on a table of just 1 record)

I’m afraid I have no explanation.

1 Like

I think if you just put text as the action target it may be interpreted as the name of an app. These actions are definitely expecting a deeplink, not just the name of a view in the app. LinkToView() just constructs the link for you. If it worked before like this it may have only been incidental.

3 Likes