New Bug Encountered: expression assistant different with App

In a virtual column I have the simple test expression 20/16.
The column type is TEXT.
In the expression assistant, the result is “1”.
In the App the result is “1.25”.
I know I can workaround this by using FLOOR(20/16).
But in fact it’s confusing, when the results are different.

1 Like

Interesting

I just tried 20.0/16, that’s how you produce non-integer results in many languages. Expression assistant returns 1.25.

Given that the expression assistant often throws an error about type mismatch between the return value and the column type, I assume there are two different processors happening, one to produce the expression result, and one to cast it into the column type, if possible.

I’m not sure if this can be considered a “bug” or not. I suppose knowing the end result, and not the intermediate result would be better though.

1 Like

When the result is different, it means there is a small bug. They should give the same result.

2 Likes

@adam FYI