New Bug Encountered: new Attachment Template won't work when Workflow is copied

Hello, i promise i have looked into community before but haven’t found something similar.
When i copy a existing Workflow and change the Attachment Template, it won’t work and can’t be viewed when i click in the View button.

If i click in the View button, this is what i get, a white screen and also Workflow doesn’t work.

To be sure, i manually created a new Workflow with exactly same parameters and New Attachment Template and it worked normally.

Were you intending to use the same template with the previous one? Couldn’t get the intent really. Or will you be using another template and though you have changed the docId manually, you cannot view the template?

No , it is not the same Attachment Template. I just copied the Workflow clicking in the button Copy. After that i remove the current Attachment Template, add a new one, and then the problem happens.

It is as you said “Or will you be using another template and though you have changed the docId manually, you cannot view the template?”"

I believe when you choose a template from the gDrive via the blue paper icon, AppSheet somehow caches a preview of the template so that you can view it easily without searching for that template amongst your files. When that docId entered manually, I’m pretty much sure that the editor cannot cache that preview.

May be worth trying this to understand it better:
Just create a copy again from the new copy you have created, change the docId manually and instead of SAVE, try with SAVE and VERIFY.

THis is interesting , however i may not have expressed myself well. When i say manually entering, i wanted to mean that after i copy the Workflow, i delete the current Attachment Template, click in the Icon to add the New Attachment Template directly from Google Drive. I am not writing the text DocID=14ke4 …

However do you think clicking in Save and Verify would i get rid from the problem? Do you think it is worth i make a trial?

Provided you are using the file picker icon, you don’t even need to delete the previous/existing docId from there. Anyway, worths trying SAVE & VERIFY. What’s the harm? :hugs:

1 Like

eheheheh true.
I just tried the following:

  1. Copied the Workflow.
  2. Tested the current Attachment View, it was ok.
  3. Clicked in SAVE.
  4. Clicked in the Picker Icon to choose another Template from Google Drive.
  5. Clicked in the View Icon, it didn’t work as i described in the topic.
  6. Clicked in SAVE & VERIFY.
  7. Clicked in the View Icon, it still doesn’t work and i can’t view the new Template.

So it didn’t work with the SAVE & VERIFY.

Well then, I may advise contacting support@appsheet.com directly on the issue.

2 Likes

Hi @Thiago_Calcagniti
Have you tried clicking on create and then view, go to the new template, deletethe contents of the new template then paste a copy of your template into the one appsheet has created for you. Sorry if I am way off track here but this is what I sometimes do.

2 Likes

Hi @Lynn , i tried and it worked. It seems to be a good a work around. However the template Appsheet creates when clicking in the button Create is a Google Doc and i prefer to use a Word document as Template. But i think this can be accepted as a Workaround. I will mark it as solution, but will send now a mail to appsheet support.

Thanks for your input.

1 Like

We’ve been changing things internally with workflows and templates. May well have broken something. Will investigate and respond to the support ticket.

4 Likes

Hi, @praveen would like to inform you something that may help in the investigation.
I have also sent this to the support appsheet which i am already in contact.

I have continued working with the Workflow and now even creating a new Workflow it is not working. Also when i click in Create Attachment Template, it doesn’t work as well nothing happens.

I still have one WOrkflow working in my app, so took a quick look into the links generated just before the Template opens from google drive.

Link from the good Wokflow : https://www.appsheet.com/template/showworkflowtemplate?ruleName=CandidatoTransferido&tableName=Transfers&templateType=Body&contentType=PDF&actionIndex=0&appId=d67bbe34-7a6c-4e74-a67e-dc69179ac35d&fileName=DocId%3D1W67zZh-Fjv-R2rANq8goFzicKQOdAaTw&dataSourceName= google

Link from the failing Wokflow : https://www.appsheet.com/template/showworkflowtemplate?ruleName=CandidatoTransferido&tableName=Transfers&templateType=Body&contentType=PDF&actionIndex=0&appId=d67bbe34-7a6c-4e74-a67e-dc69179ac35d&fileName=DocId%3D1W67zZh-Fjv-R2rANq8goFzicKQOdAaTw&dataSourceName= GEM

If you look into the end of the links, the name of the Sources are different.
My account is using data from different sources, for this particular app, sourcename is GEM.
I am working also as Co-Author in this app.

And i dont understand how is it possible the first workflow is working if the SourceName is wrong in the link. It is probably because in the account where the App really belongs the name of the Source is google. And if i try to attach as Co-Author , from my account mapping the same GDrive account named differently as GEM (in my case), then i get the issue.

So in maybe making the link to work without the SourceName parameter , might fix the problem.