New Bug Encountered: Photo not appearing

Our app is a form. There are several aspects of our app that ask for a photo. One is required. We have found a few work arounds to our problem, but still want the app to work as designed without complications.
Problem:
When asked to upload a photo user is given the option to take a photo or use one from the library. Our users need to take the photo. On occasion, they take the photo, choose “use” and the screen returns to the form without loading the photo. As if the photo was never taken. If the user clicks again to upload a photo and chooses “from the library” the photo that was just taken is the first one they see and use. It appears without problem and the user moves forward.
In some cases the user does not see the photo that was just taken in the library and must go out of the app, take the photo with the iPad’s camera, go back into the app and then upload it from the library.
We have refreshed and restarted the app, but the problem continues, not constantly, but enough to be more noticable than just a fluke.
Anyone else experciencing this issue? Any ideas what could be causing the problem? Any ideas on how to fix the problem?
New to all this.
Thank you!

@gil Any thoughts?

Hi @Michelle_Cameron
I had this problem about a month ago. Im not sure what fixed it but I did uninstall and reininstall appsheet and also I think there was an upgrade for my phone.

@Michelle_Cameron, If the users saves the form and syncs the app, does the photo appears after the sync?
Does this issue occurs only on iOS?

We are only using iOS. Since we have not been able to save the form that was being worked on because the photo was required, we had to sync and restart a new form. Thank you

Thank you

So when you try to hit the save button it wouldn’t save saying you’re missing a required field?
I’m asking that since we had issues with the image preview in the past, where the selected image was recognized by the app, but its preview wouldn’t show in the form.
Also, would you mind if I take a look in your app? I’ll need the app and form names for that.

That is correct.
TBL Medical Disclousure
Form Responses 1
NOTE: This was never an issue during development testing AND testing live until the weekend of 11/10 when the instance of the photo not appearing when “take photo” was choosen but it could be found when choosing “from library” when tryinig again. There have been several incidents between 11/13 and 11/18. The 13th was to be the first day of use with customers when this happened and launch was ditched until the following day. I cannot tell you how many times or when exactly the issue happened between 11/14 and 11/18, but I can say it was not everytime. In these incidences the photo that was taken but did not appear was not visible when the customer tried to choose “from library” when trying again. We did try Lynn’s suggestion to uninstall and reinstall the app earlier today. Since I didn’t hear about any problems afterward I assumed that worked, however just heard a staffer had to go outside the app to take the photo again this evening. Thanks for the help.

1 Like

Hi @Michelle_Cameron,
I tried several times, but couldn’t reproduce this issue.
I noticed you’re using a thumbnail column type. Could you please try changing the column type to image and see if it fixes the issue?

Thank you Gil. Sorry for the delayed response. The uninstall/reinstall worked. I also had a hard time replicating the issue on other devices. I will say that while building out the form/app at some point one of my “photo capture” areas was listed as image instead of thumbnail and the ability to take a photo did not appear. I am keeping an eye on possible problems and appreciate your help.

1 Like

Thanks for the update @Michelle_Cameron,
Please let me know if this issue reappear.