New Bug Encountered:The caller does not have permission

Hi all,

I met an issue at changing app owner.
I made a few research, looks similar to the one with [Fouad_H_Saad1], but even if I try to follow instructions, I cannot solve it.

Here is what I get at syncing :

Here are my settings on the tables (for this example : “Mouvements”) :
Capture2


dev ==> me, as editor of the app
galster ==> owner of the app

Any clue of what to do at this stage ?

Thanks

Aurelien

Have you checked that all tables are using the “as app creator” option?

1 Like

Hi Aleksi

yes I just checked, all the tables are on the access mode option “as app creator”.

Hi @Aleksi

I checked again the “as app creator” option.
I removed the formula in the “are updates allowed” option.
I checked the authorization on the spreadsheet, I am still the owner.

However, I still cannot sync the app when I proceed to a change.
Do you think I should look further on the google sheets authorizations ?

My google account depend on a G-suite domain, however the other apps are still working, so that I guess that if the owner had proceed to any changes, that would impact all apps and not just this one. The error started occurring when I swapped the app ownership.

Thanks

Are you using Excel?

If your spreadsheet is open, you’ll get that.

For that reason I am using now Google Spreadsheets

Hi @AlexM,

Thanks for your answer.
I’m using Google Sheets as well.

Grasping at straws here.

Because it looks like the error is coming from Google, I wonder if you are hitting the recent Google Authentication problem in a different way - if you haven’t encountered it yet?

First, review the article below and have it handy to refer to in a separate window. Then, from AppSheet Logout. Now, log back in using your Google account.

If you get the “AppSheet is not authenticated error message”, refer back to the article to resolve that issue (its simple).

1 Like

The problem is definitely because you changed app ownership. The new app owner doesn’t have access to read the Google sheet (which is probably still owned by the original account). So there is a (403) permission error.

1 Like

Hi @WillowMobileSystems and @praveen,

@WillowMobileSystems I think I was not touched with that issue, fortunately : none of me or my first user had the warning message at authentication.
I tried what you say : to log out, then log in (even with two different google accounts), but the issue remained.

@praveen the folder (including google sheets) belonged to me, and my first user could at first use the app ; in the opposite way, once the app belongs to him and with me as a co-author, I cannot explain we can not sync it anymore ? Must be what you describe, but I’m afraid I will make a mistake at trying to share it.

EDIT : I tried a different way (very hard-making way) : I logged in as the new owner, then copy the app from here, and shared it back to me as “dev”. I cannot explain why, but that worked.
It must be something related to what you describe, but that goes beyond my understanding.
However, my main concern was for it to work, so…I’ll deal with that.

Thank you so much to you both, with your two suggestions I finally successed in solving it.