New Table overwriting another table

When I add a new table into my app it shows in the tables view, but seems to overwrite the last table I added in the columns view.

Is there a limit to the number of tables in an app? I’m on the Pro plan
It has 11 tables so far.

Following

Are the two tables based on sheets with the same name? If you make a new sheet with a new name and try to add that, does it have the same problem?

The two tables have different names.
The new table was a copy of the google sheet of the first table, so I thought it was something to do with that.
But then I went back to an older app version and then added a totally unrelated table and the same thing happened.

This seems to be ok now.
I’ve added a couple of tables and it works.
Must have been a glitch at the time

@Adam I’m having this same problem again.
I added a table, which shows in table view, but in column view the new table has overwritten the last table.
Any ideas what causes it?

Hi Simon,

Let me make sure I understand, when you added a new table and looked at the columns you noticed that the columns of the new table replaced the columns of an existing table (in Data > Columns)?

Can you tell me the name of the old table, the new table you’re trying to add, and the affected app name? This sounds like it’s worth investigating.

Thanks,
-Nico

Hello Nico,

You understand correctly.
I tried it again today and the same thing happened.
I can’t leave the app in a broken state though as we’re using it.

I just copied the app it and did the same thing to leave it broken for you to look at, but the table added correctly in the new version.

I could break it when we finish today, then you can have a look while I’m asleep :slight_smile: I assume you’re in the US.
Then I can go back to an old version in the morning before they start again.

Is that worth doing?

Thanks

Hello Nico,

Tried it again to leave it broken for you to check and it added the table properly.
Shall I let you know if it happens again?

Hello again Nico,
Yesterday I added a table and I had the same problem, It overwrote a current table.
Today I’ve added the same table into the same app and it worked fine.

I know this is probably impossible to check to see what might cause it, but thought I’d let you know.

It happens on Google sheets. I don’t think it’s happened using Excel in dropbox, but I will try to check that next time it happens.