Not Editable if field is SAVED with specific value

I have a Status field with 3 values:

  1. Pending
  2. In Process
  3. Completed

The field is editable, but once the record has been SAVED with Status = “Completed” the status field can NOT be editable any more.

The issue I am having for now is that if when editing the Status field I select (no saving yet) “Completed” than I can Not edit it again:

I understand from where your headache is coming from. Alternative workaround.

There are few possible workaround, but this is a workaround it came up with in my mind.
First you creat physical field, called LockOrUnlock and default value is set to “Unlock” through initial setting. And always hide this field from any view.

Create action set this field value to “Lock”.

Create workflow to fire this action only on the condition of

and(
[_thisrow_before].[Status]<> [_thisrow_after].[Status],
[_thisrow_after].[Status]=“Complete”
)

For status field, set up editif condition, only it is editable when LockOrUnlock field value is “Unlock”

2 Likes

Another workaround… NOT(LOOKUP([_THISROW].[ID],“TableName”,“ID”,“Status”)=“Completed”) in Editable? option will do that job because you haven’t saved that value yet.

4 Likes

I just tried that and it worked Perfectly! Thanks a lot, @Aleksi

also thank you @tsuji_koichi for always taking time to help the community!

1 Like

You’re welcome