Not showing the the format rule in the detail view

I have a view of classes and a format rule that puts a icon by the classes that have a cost >0. When I click on the item in the list and view the detail I do not want to see the by the class name.

Is there anyway to do that? thank you…

It sounds that you do not wish to show the format rule icon in detail view and wish to show it only in the summary (table or list )view.

If so , you may have an expression something like below in the format rule

CONTEXT(“ViewType”)<>“Detail”

That is doing it, but when I go to the detail and then go back to my table view the formatting is not there until I do a manual sync.

I believe that will happen for the existing records as the new format rule gets applied. I believe you may not observe that behaviour for the new records being added.

Could you please confirm?

I have found its pretty much universally better to have format rules use equality ( = ) over
inequality ( <> ) to avoid random issues.

1 Like

Thank you @Bahbus for your valuable input.

@llheath, Based on input by @Bahbus , you may wish to change the expression to

CONTEXT(“ViewType”) = “Table” or CONTEXT(“ViewType”) = “Deck” , depending on the summary view you are using.

Thank you so much. I have a tableview on the Menu and I see the formatting there, but when I go to the detail I don’t see it(which I want, I do not want the formatting to show on detail), but back to the table view and the formatting is gone.

Also I noticed if the view is in a dashboard I do not see the formatting at all

And (CONTEXT(“ViewType”) = “table” , [Next Approver] = Useremail())

Another solution is a virtual column [Class Name No Format] and display this in your detail view and not in your deck view and vice versa.

2 Likes

Could you please share a screenshot? Is formatting disaapearing for ever in the table view after return back from detail view? Typically if the user goes to edit from table to detail or form view and tries to change the field associated with the format rule expression([Cost] for example) , the format rule driven icon /formatting will show up in the table or summary view after the record syncs.

Since , dashboard is also another type of view, please try an expression something like

AND(OR(CONTEXT(“ViewType”)=“Table”, CONTEXT(“ViewType”)=“Dashboard”), [Next Approver] = Useremail())

Since comparison operator is now changed to equality , the expression will need to have all those views where the format rule needs to be applied.

Here it is, first screen is view in dashboard (thank you it is working), 2nd screen is what I see when I click on a record(looks good). When I click Back arrow I am expecting to see the same thing that I see in screen shot one but as you can see there is not an indicator, the format rule is not showing.

@llheath Thank you for sharing the details. I also tested with similar test conditions. Yes, you are correct that the reverse navigation back from detail view to table view seems to drop off the applied format rule.

I then tried to search previous posts and found a similar post below. It looks like format rules seem to be dropping off with CONTEXT() expressions.

I will request @Steve or @Aleksi for further guidance in this regard.

1 Like

yes, sorry I thought I responded.
I did have it setup as you did, but in my Grouped action the format rule on the button had a condition “If status=gm approver” and the 1st action in the group action as setting the nextapprover to vpapprover.

I removed the condition on the format and just have to be careful where I “show” it.

The grouped action is doing this:

When I click the icon to approve, the form saves and syncs which takes awhile Then the comment field pops up.

We could live with it but not ideal because most of the time they do not even want to put in comments

Than you for your help with this, I really appreciate it.

1 Like

This looks like a bug. Since @Kirk_Masden has already posted about it, I propose others that see this problem to either comment on his post, and/or send email to support@appsheet.com.

1 Like

Thanks everyone! As I wrote in that thread, I later found that I could get around the problem by putting the text I want to format in a virtual column that I only show in that context. That allows me to avoid the CONTEXT() expression; the format rule doesn’t need a condition.

This strategy also has the advantage of getting rid of warnings that format conditions can cause:

2 Likes

Thank you @Kirk_Masden, your suggestions for the workaround are useful.

2 Likes