Now what was the name of that action . . .?

If you have lots of actions in your app it can be hard to remember what you called each one. Here’s a little trick to get the name of an action so that you can find it more easily in the editor:

Action name

If you “drag” your action inside the browser like this, you should be able to see the name, or at least the first part of it.

By the way, I hope that someday AppSheet will make it possible to download and/or search the text of all actions, expressions, etc. in a given app to help us figure out what’s what in an overgrown app. I’ve written about this here:


Wow, I better be careful what I name things…
“Stupid button that Jimbo wants”
“Sara is too lazy to click two buttons”
“Billy has to have a smiley face check mark”
All have to go… LoL


I hadn’t thought of it that way. :slight_smile: I don’t think this works on phones (haven’t tried it, though) but if someone is using an app on a computer browser, they can probably do the same thing.

No doesn’t work on my phone :disappointed_relieved:

1 Like


I was wrong about the lack of a way to search for this kind of information:


Regarding ‘searching the text…’, have you tried going to Info > Properties > App Documentation and downloading the documentation page?

Look for “The documentation page for this app is available here.”


Thanks @Peter! Yes, that’s what @Fabian has pointed out to us.

Oops, missed that reply, nice!

1 Like


Thanks. I never knew that existed.

Hi @Lucinda_Mason! This new feature may be of interest to you too:



1 Like

The editor has improved in many ways recently. Unfortunately, mostly positive changes in the editor have made this tip obsolete and there isn’t a workaround that I know of that works for all actions. With inline actions, you can copy the text of the line and the action name will come with it when you paste it. For other actions, however, you just have to figure it out some other way. So, I made a request for a right click to copy the action name:

1 Like

This tip, which no longer works due to changes in the AppSheet interface, has been replaced by the following one: