Object reference not set to an instance of an object

Since I was updated to the new editor more than 30 hours ago, I keep seeing the error “Object reference not set to an instance of an object.”

I was regenerating a table, when the update was rolled out.

Whenever I try to regenerate a table, I stop seeing the option to edit its columns or view its data.

I have managed to restore the app to an old working version, but

  1. Changes in App expressions don’t work in the app
  2. Formatting rules work without any issues

Even if the app(old version) works, the error is still displayed in the editor - “Object reference not set to an instance of an object.”

the new update should’ve only affected visual on the editor from what I’ve seen posted.
Recommend contacting support@appsheet.com don’t think I’ve ever see that error persist in the editor. If I had it, a refresh of my window would remove it.

2 Likes

Definitely contact support@appsheet.com. You can also try switching back to the old interface by adding &new=0 to the app editor URL after the ? but before the #:

https://www.appsheet.com/Template/AppDef?appName=...&new=0#...
1 Like

I had already raised the issued yesterday, but still no progress.

The issue is only affecting one of my apps. When I regenerate a table in a different app, everything works as usual.

@Steve Kindly check when this issue will be resolved. It has been over 4 days, and still same bug in the editor

Have you contacted support@appsheet.com?

yes, multiple times

We have found and fixed the problem.
​We plan to deploy the fix today Oct 1, 2020 at about 1:00 PM Seattle time.

1 Like

Now all my app with that error message is showing NO ERROR!

Thank you Phil-san for finding and releasing a fix to this.

2 Likes

Thanks Koichi-san, Praveen deserves the credit.

1 Like

I have same problem showing error “object reference not set to an instance of an object” whenever i try to edit or add data to specific table…i have already contacted support team of the appsheet…but still no progress…if anyone knows the solution…please help me out…i am delaying my work here

A possible attempted solution is deleting the table and re-adding it.

I am unable to find your support ticket. Please contact support@appsheet.com again for help with this.