One day short on calendar view when events longer than one day


When I have an event with start date 01.01 and end date 01.04, only 01.01-01.03 is marked in the calendar. Does anyone know why? And how to get it right?


Do you have a time-column to go with the event? Or only a date?

If you only have a date, it may be looking at the end-date as starting/ending exactly at midnight.

Either add a Time column to the sheet, or change your Date to a DateTime.

NOTE: If there’s no real time involved, you can add a virtual column to provide a constant time value that gets added to each event.

In one app, I counted the number of events per day and added 1-hr to 8AM for each event. So the second event was 9AM, 3rd = 10AM, etc. This seems to look better on calendar views than having no date at all.


Perfect, thank you! But it seems like i can’t choose a VC thats hidden as start/end date in the calendar view? Is it correct that the column has to be visible?

Not exactly. You can use a formula to hide it from the user. It just can’t be set to always hidden, because that removes it from the dropdown options of columns to display on the calendar.

Perfect! Thank you very much :smiley: