PDF not opening on android

Hi everyone,

I am testing an app which one of the forms has a column type “File” which has a pdf selected and saved.

when I try to open the pdf from my computer the browser opens another tab and display the pdf.
On my cellphone (note 10) it does something crazy and it doesn’t open the pdf.

any thoughts?

Anyone can help with this?

Define…

Hey Matt, Thank you so much for reaching out, I’ve seen most your youtube videos and have been of great help!!!

So, when I go to the register where the pdf file is stored and I click on it on the browser, it will open a new tab displaying the pdf.

when I do it on the android, he shows the download progress bar but it comes back to the app and don’t open the pdf file, if I try again it does a super fast (like if he already had downloaded) but still does nothing and comes back to the app

thanks

1 Like

You’ll need to open you’re device’s downloads viewer and open the file from there.

1 Like

Thanks for the kind words, they mean a lot!

1 Like

but there’s no way the system triggers the document to open?

Absolutely man!! if it wasn’t for you and Grant Stead I would be dead in the water

4 Likes

That’s a function of your device, not the app. You might be able to configure your device to do it, but AppSheet does not (to my knowledge).

1 Like

@Grant_Stead getting some love!

:thinking: hmm… it should open the pdf on your phone when you tap on the file link… testing…


It worked on my phone, I imagine this might have something to do with the phone… a Note 10 maybe? Maybe something specific to that device?

You might need to report this to Support@appsheet.com

Maybe you need to set a PDF default app… but it should ask you what you want to use to view the file… hmmm…

2 Likes

I’ve set the default app for pdf, still no go…

I would guess the file isn’t an actual PDF or is corrupted in some way.

I don’t think so as I am able to open it from the browser

something is definitely wrong
I am trying to replace a pdf on a different app and appsheet is not making the change even when I save and wait for refresh every signle step of the way

Can you try a different defauld pdf app. Worked in my case.

2 Likes

Also , if replacing a pdf in drive, I think clearing the BIN with the deleted ones helps.

I generally have troubles when trying to replace files, so I ussualy prefer to change their names a bit. It must have something to do with the files “coding” from google , the one that lets us have identical names of files in same folder

1 Like

Fixed!

thanks everyone

True for all non-image file types, too:

image

this is very helpful thank you so much Steve!!

1 Like