PDF not sent

Hi everyone,

I have a very very very simpel workflow where a email should be sent to me with a PDF. In this pdf the word “Hello” should be in it, just to see it the workflow can send me a pdf.

The workflows can send me any kind attachment, (csv, xml, json, …) except pdf. As soon as I change the attachment type in pdf no mail is coming in. For everything else it works.

Now Customer support is also not helping despite a pro plan.

Anybody suggestions what can be wrong? I already changed a different channel type and also does not work for me .

Thx. Robert

It’s possible the AppSheet offices are closed today for a holiday.

How are you generating the PDF attachment? Do you have a template file? If so, where is this template file stored or what type of file is it?

EDITED: Also, you might look in the Log file to see if any errors are being reported

1 Like

Yes, I created a template by using the “create” functionality. To reduce determine the error causes, I just wrote the “Hello World” as plain text in the template to see if the pdf is generated.

Whatever I do, get all the type of attachments (xml, json, etc), except the pdf format.

Thx, Robert

Please contact support@appsheet.com for help with this.

1 Like

I tried to get it solved for more then 3 days now with support@. Thx anyway, I will close this ticket not to bother anyone anymore.

2 Likes

Have you checked the log file for errors?

I have been testing and thought I had re-created it. But I am getting sporadic behavior. I have been able to generate and send a test email similar to how you have described. Though, sometimes the email takes over 10 minutes to arrive.

It might help if you could share more details (screenshots) of how you have the Workflow setup, what kind of template you are using etc.

1 Like

Got from support the following reply:

– I think the issue is not with Appsheet but with email service provider, at least I heard that our engineers are discussing with email provider team the details of the attachments loss. Anyway, thanks for the additional details.

keep you posted.

1 Like

Ahhh. Have you tried changing the Via channel setting to the other option?

image

yes, I did :-/

1 Like

Just so that our understanding is accurate, you see issues with sending attachments using either System Default or System Mandrill. Is that accurate?

1 Like

The only issue I see is that I do not receive pdf files, any other attachment-type I receive with the same template.

Mandrill System = I receive any attachment-type except pdf
Default System = I receive any attachment-type excep pdf

I even receive an OK when I test the workflow:
image

Is it possible your email provider is stripping PDF attachments?

Have you tried configuring the workflow to also archive a copy the the PDF?

image

Interesting is that the file-type PDF is not generated:

So even the archive file isn’t being created. That suggests the PDF file isn’t being created at all, and that this isn’t a mail problem.

Please post a screenshot of your template file.

1 Like

Please provide:

  1. Your numeric account id
  2. The app name
  3. The workflow rule name
1 Like

and the result as HTML for example:

1 Like

@Robert : In the intercom, you were saying that the difference here is that you are not trying to generate the PDF but rather you are trying to send an existing PDF as an attachment right? Just wanted to confirm.

No, you are mixing things up. I said that I have also another workflow where I can send pdf files, but these are existing (static) pdf files, because you asked me this:

“Were you able to send any emails with attachments before where you received the attachments and suddenly you started seeing this issue?”

In this workflow I want to send a customer a pdf (dynamic) of his gym-results.