PDF not sent

Got it. Thanks for clarifying.

1 Like

Hi Robert,

We have found and fixed the problem.
If testing goes well, the change should be released on Wednesday Jan 20, 2021 in the afternoon Seattle time.
Thanks for reporting the problem.
Sorry for the inconvenience it caused you.

3 Likes

Hi Phil,

I have tested it and there is still no pdf. I changed the format to JSON then it worked with JSON. I also tried both Systems with no success.
BR. - Robert

I tested it on my deployed NHTC-360 app. Or did you fixed the issue on an other system?
BR. - robert

Hi Robert,
The change had to go through the build and test process.
It has not yet been deployed.
If testing goes well, the change should be released on Wednesday Jan 20, 2021 in the afternoon Seattle time.

Phil

3 Likes

Thank you everyone (Appsheet & Community) - The Change/Patch has been tested successfully now!
Many thanks!!

Robert

3 Likes

Hi Robert,

Thanks for the update.
Glad to hear that it is working again.
Sorry we broke it.

1 Like

Hi Philip,

Thank you for your effort and explanation.

Best regards,
Robert

1 Like

Team,

I have just been working with Support for the last couple of hours and had exactly the same issue.

For about 1 hour earlier tonight it would not ‘send a PDF’ looking at the Audit Logs there was ‘success’. We had not changed anything on the templates for more than a week. About 2 hours ago it started to work again. Is this intermittent ? thank you. It is working at the moment but not confident that it will be for daily reports tomorrow Australian time. Updates would be great.

1 Like

Hello,

Similar issue here, many email workflows with pdf attachments doesn’t arrive at recipients. I’ve been trying all I could think if for the last two hours, it impacts our business processes.

Everything was working fine 12 hours ago.
Everything shows up as succes in logs
Attachment doesn’t save in google drive either
Email receipients tested with GSuite emails , and free gmails
Tested with default and with mandrill
In the past I did not apply for the new pdf generating updates.

I do see that “large payload” in logs, I don’t know if it’s a display resume or it means something. I can not manually execute tasks for those large payloads.

Do you have any recommendations?

Thank you.

Update : same workflow , modified with no body or attachment template, doesn’t send email ( one time it did, 30 mins later-gsuite and gmail emails). Same workflow,with autocreated templates, same issue , even after eliminating tables from templates.

Strange is , that a report with table template (older one) , works just fine

1 Like

Hi
The same problem, I already wrote to tech support.

Thanks. I did not write them so far, because I saw it’s a general issue, not a specific one to my app, so i was expecting a public solution

1 Like

Hi all. We have identified the issue and we are investigating at this moment what the reason could be. We will ping you when we have found the root cause.

Aleksi

5 Likes

Thank you. In my case, I started to receive workflow emails from my tests done 0,5-1 hour ago , but only the ones with no attachments.

Mine works randomly.
From 10 records, missed one and when I retried it worked and then again, none worked.

Sent an email to support.

HI All, Thierry from Appsheet here.
We are aware of the issue, though not sure why yet.
It seems it is restricted to only workflow with PDF attachement.
We are not sure why that triggered this morning and will be continuing our investigation until we find out.
For now we are reverting the build to Friday’s state (it’s in progress) in the hope it puts the service in a working state again for you all.
Once that is complete, I’d love your help to confirm that all your workflows are triggering again with no other side effect.
We will keep investigating through the day and will keep you updated as we find root cause, solution and remedy to strengthen the service and avoid this situation again.

Thierry
We

Hi All,
Our servers are now back with Fridays’ build.
Things should be working as of Friday night again as a result.
Can I ask everyone to confirm whether you are able to trigger your workflows with PDF attachment again?
Thank you
Thierry

1 Like

My PDF’s can be sent using the test functionality.

THank you Robert for confirming