Please install Google Chrome to continue with the login process

Hi folks,
I’ve been using an app for personal time tracking.
I’m on Android

Suddenly Appsheet has started asking me to Login.

Nothing wrong with that. But when I click the google login I get a screen saying “Please install Google Chrome to continue with the login process”. There is only one button. INSTALL

However, chrome is already installed. So clicking on the install button takes me to Google Play app which confirms that Chrome is installed and only presents one sensible option which is OPEN

Now I click on the “Open” button in Google Play it opens Google Chrome but doesnt open any Appsheet login page (which was promised by the original message when I started Appsheet.

This cycle never actually allows me to open the Appsheeet app. So I can’t use the Appsheet app with any user.
But I can log in fine from Google Chrome and use my Appsheet app from within Google Chrome.

Has anyone noticed this broken behavior?
Note, I’ve already uninstalled and reinstalled Appsheet and my short cuts

Hey Andrew,

I’m not sure if this’ll solve your issues, but if you haven’t already, check out this post:

I can’t tell if your bug is related to the particular issue Praveen identified, but the fix (if it works) only takes 15 seconds, so it couldn’t hurt to try that as a starting point.

-Eddie

Thanks Eddie,

No I’m fairly sure this is not related.

To be clear … the problem is that either
a) Appsheet doesn’t check to see whether Chrome is installed
b) the check isn’t working

If that was sorted and Appsheet knows Chrome is installed then we could maybe get to the point of checking what kind of login failure this is.

Again to be clear, this is not presenting as a “login problem”. I can login fine if I use the browser to go to my Appsheet app.

Rather, it’s presenting as a bug that affects Appsheet’s ability to reliably detect if Google Chrome is installed on the Android platform.

1 Like

What device type is this? Google requires using Chrome when going through the OAuth login process, so we have some code to detect if Chrome is installed. If we can’t find Chrome we show the page you’re seeing, but there may be some issue in our detection logic.

@Gil

1 Like

@Andrew_Smith1, Which browsers are installed on your device? And which browsers is set as the default browser?

@brian thanks for that.
Yes I guess that under some circumstances the detection isn’t working quite right. I’m on Android

@Gil this is a good question.
I have Firefox, Opera and Chrome

Chrome is the default

I have also tried

  1. uninstalling/reinstalling Chrome
  2. uninstalling/reinstalling Appsheet
  3. making Firefox the default and then re-setting the default to Chrome
  4. revoking OAuth permissions for a particular Google/ Appsheet and re-logging in / re-authorising OAuth

In retrospect, (4) was silly to even try because at the point that Appsheet asks me to log-in, the Google account being used is as yet not specified, so therefore must be irrelevant whether the OAuth for any particular Google account is currently active or inactive.

Note that (as you’d expect) I can log in normally from the Appsheet App with a Microsoft login.

I see,
And which device are you using? (model)
As you suggested, the root of this is a bug in our Android app that, doesn’t use the correct browser some times when the device has multiple browsers. We’ll need to fix that, but if you’re working for a quick workaround you can uninstall Opera and FF (maybe just Opera will be fine too), log in to AppSheet, and then reinstall the other browsers.

@brian sorry, you asked about device type
I’m on a Sony z3 compact with Android 6.0.1 and all updates are …well up to date.

I’ve been using Appsheet on this phone for 2 years. Before that I was developing stuff using ODK.

This is the firs time I’ve been completely locked out of Appsheet.

However, I’m replacing the phone so if you want I could even part with it if it will aid medical science …well Appsheet! Which is awesome by the way.

Will do. @Gil g
However, I’ve had both browsers installed for a year or so. And Appsheet worked fine with the same conditions.
But let’s try.
Tomorrow I’ll get back to you helpful ppl

Right.
The workaround is

  1. uninstall Firefox, Opera and all other browsers (save data first of course!)
  2. uninstall Appsheet
  3. log in to https://myaccount.google.com/permissions and note the TWO sections that revoke the permissions (a) to “Sign in” to Appsheet (the lower section) and (b) for Appsheet to use the accounts data (the upper section). I revoked (a) first and then (b). If you revoke (b) first you may get slightly different results.
  4. reinstall Appsheet
  5. Start up and log in.

THIS time Appsheet doesn’t challenge you to install Google Chrome and instead takes you to a login page where you can successfully log in again. Yipeee!

HOWEVER … (boo!) all the apps were now broken due to being unable to access the google sheets data because of the revoked permissions (which for some reason were not re-instated on login into the Appsheet App). So you need an extra step. I suggest that the app explicitly checks for this because it evidently doesn’t and assumes that OAuth access to the google sheets will come along with login permissions (apparently they don’t … or at least didn’t).

  1. Log in to Appsheet on the Web portal to trigger the request for OAuth access to the google data on which the Appsheet apps work.

All working as before.
Now to reinstall all my favourite Browsers and hope I don’t have to do all this again.

@Gil
Just for my satisfaction, can you let us know when Appsheet has been updated to correctly deal with the case that started all this (i.e. the non-functioning check of whether Google Chrome is installed which is apparently caused by the presence of other installations like Firefox and Opera).

@Andrew_Smith1,
I’m sorry you had to got through this long process just to sign in. Although I’m not sure if I understand why was revoking the Google permission necessary.

It might take a while to fix this, but I’ll post here when it’s out.

@Gil
No problem. Hope that documenting it has helped. Great Apps don’t grow on trees.
Why was revoking Google permissions necessary?

I’m not sure it was ‘necessary’. Remember that my objective was finding a set of actions that were SUFFICIENT. If someone else wants to investigate further to find out which of those actions were NECESSARY then they can play around with my solution and try missing out steps to see what works and what doesn’t. Personally I didn’t fancy installing and reinstalling things too much so I did everything I could think of.
:slight_smile:

@Andrew_Smith1,
A fix for issue would be included in the next update (13.7). The update will be out in the next couple of weeks.

I’ve discovered another workaround which may or may not suit people having the same problem.
I created Microsoft logins for all the users while keeping the data store for the actual app as google.

Microsoft doesn’t have a problem with logging in and there are a lot of other login/online/offline problems that I’ve solved by doing this.

@Gil
Looks like I spoke too soon. A related problem has now appeared involving the displaying of the same login screen. I’ve documented this as best I can.

In my humble opinion there may be some connection.

Hi @Andrew_Smith1, Sorry for the late response.
I’m pretty sure the two issues are not related. I’ll try to explain:
Google’s sign in page can’t be loaded with any browser so when you are trying to sign in with Google, we need to choose which browser (from the ones installed on your device) will open that page. If we’re asking you to install Chrome although it is already installed on your device - we are obviously not doing a good job choosing the right browser.
This issue is unique to Google sign in and is not related to being requested to sign in repeatedly.

Have this problem repeated itself in version 13.7?

Hi @Gil
Well the challenge here is that I already implemented my workaround above (moving to a
Microsoft account for sign in. So I couldn’t rightly tell you if it was my workaround that fixed the problem or version 13.7.

While we are on the subject …how do I even check the Whatsapp version on Android? Because clicking the ‘About’ button in my apps tells me about my app, not about the Android version.

Thanks for engaging with us on this. It’s very helpful.

No worries, you don’t have to go out of your way to test the new version. That’s my job :slight_smile:

To check the app’s version you’ll have to go to the app info page on your device’s settings. On most Android devices you can get there by tapping and holding the app’s icon. The version should be all the way to the bottom.