Problem with adding new tables from data source

Until recently I was able to add new tables from Sheets in the app that I’m a co-author. But suddenly the option was gone, please see the image below. Was there any changes regarding this or am I missing something?

Hi @Jsenn
Are the sheets shared with you?

Yes, it is shared with me.

Another thing I notice is I can still add table using the “suggestion” beside the Add New Table button.

I think the restrictions for team-data sources has been… enforced; perhaps it wasn’t 100% before and now it is.

Looks like the person who owns the app needs to share their data sources with the team

2 Likes

Thanks for the information. I’m still confused though. Just a background regarding our setup. I’m the one creating the apps using a free account, when it is ready for deployment I transfer the ownership to another account where it will be deployed. The data resides in a shared Google drive folder which is associated to the Appsheet’s account where all the apps are deployed. Once it is deployed I manage and update tables as a co-author. Until a couple of days ago I was able to that but now I can’t.

I was reading through different articles and found about Team Shared Data Source.

https://help.appsheet.com/en/articles/954445-shared-authoring-of-apps

According in this article co-authors can only add tables if it is from a Team Shared Data Source so that might really be the case now. As far as I can tell this is an Enterprise feature and we are only running on a Pro plan but its weird that we were able to do what we are doing until now.

I also found this under My Account.

We tried to add a data source in the Pro account but nothing changes, it still says “+ New Data Source”. At this point I still have no idea where to go and I’m not sure if the above is related to our current concern.

How do you guys manage and update your deployed apps as a co-author?

As someone who’s been a full-time AppSheet consultant for 5 years now, being able to add data sources to an app that’s shared with you has never really been a thing. It might have worked once and a while, but adding a new data source has always been restricted to the “owner account” of the app.

You could add tables… from a data source already connected, but you couldn’t add new data sources.


When this situation arises, I either:

  1. Get the person who’s the owner of the app to add the new data source; or
  2. Get the credentials to the account and add the data source myself.

When I build apps for clients, I’ll start a new gmail account specifically for that app; name is something like:
Apps_Name.app@gmail.com

This way anyone who needs access to the backend can be given the credentials without compromising anyone’s security or accounts, everything is housed under one account one drive, etc.

4 Likes

I apologize if I was not clear. What you said was what I’m trying to say. Normally this is what I can see when adding tables.

Now this is the only thing that appears when adding a new table.

For now I’m able to add the new tables through the suggestion, its a bit weird I would say but at least it works for now.

image

2 Likes

Apologies, I misunderstood. :slight_smile:

Indeed… this is a bug. Reporting to support now.

3 Likes