Problem with Bot Email

Dear, I am facing an issue with email automation which will be trigger if a column’s value is changed.

Firstly, my app is not a deployed app, it is still a prototype, I have create the bot to handle the event and sending an email.

I have check the bot with the provided “Monitoring” features, the chart for the bot status is completed.

And I also check in the audit log, and it also show that the email is success send.

But the problem is, I didn’t receive the email, I have try several time, I even tried to re-create the bot, but it still not helping.


The log entry you show confirms that the Bot was triggered but it doesn’t reflect whether the Process or Steps executed.

You should also take a look at the Bot Monitor. You will find a button at the top of your Bot configuration panel to launch it. Look for any errors reported there AND that your specific Email step was executed.

If the Monitor looks good then the next thing to inspect is the Email step to make sure it is configured correctly. As for email addresses, for undeployed apps the email will automatically be sent to the email address you are logged into AppSheet with. So make sure you looking in the correct Inbox AND that the email itself was not funneled into your Spam/Junk email folder.

Next check that your email service is good and that the AppSheet sourced email is not being blocked for any reason.

If all above seems good, then please post images of the Email step in your Bot for us to look at to see if we can spot anything causing an issue.

1 Like

Dear, I think I know why.

I understand that, if a non deployed app, it will email to the app creator.

But now, even app creator also not receiving the email, I guess is the app have been inviting other user to sign in, that’s why it now even not email to the app creator.

1 Like

If you are referring to adding “test” users, I don’t think that is the problem. All functions should work. If an Email is generated, by ANY test user in an undeployed app, that email should be sent but ONLY to the app creator email address.

1 Like

Dear Willow, thanks for helping.

Ya, understand that the email will be send to the app creator if it yet to deploy, but unfortunately app creator didn’t received the email.

I have check in the Bot monitor, but everything seems fine.

Why am I suspect the email doesn’t sent out due to I have inviting other user to test my app, is it because I just run a deployment check, and I get the error message as below:

That error message would affect attempt to physically deploy the app. It should NOT impact running of any functionality under the FREE plan. Something else is preventing the email from being sent.

The only way we can help more is if you were to show us your Bot implementation - the Event, Process and Tasks.

1 Like

Dear Willow, thanks for helping.

I still have no any clue of what wen wrong, attach as the Audit Log:

And below as the detail for the email action:
Action Details
Email Details
Properties:
{
“EventType”: “Change”,
“InvokedBy”: “Update”,
“AppTemplateVersion”: “1.000227”,
“Process Name”: “Email Asset Master Full Report Process”,
“ServerRegion”: “us-west1”,
“TableName”: “Reporting”,
“OperationUpdateMode”: “UPDATES_ONLY”,
“EventMatch”: “Workflow event successfully matched”,
“IgnoreSecurityFilters”: false,
“Condition”: “=AND([Report Name]=‘Asset Master’,[_THISROW_BEFORE].[Printed Count]<>[_THISROW_AFTER].[Printed Count])”,
“MatchesCondition”: “True”,
“Task Type”: “Email”,
“Task Name”: “Email Asset Master Full Report Task”,
“Warnings”: “Warning: App version 1.000227 is not deployed. All emails are therefore being sent to the app creator. This email should have gone To ‘uda.asset.super.user@gmail.com’ CC’ed to ‘’ and BCC’ed to ‘’”,
“EmailTo”: “uda.asset.super.user@gmail.com”,
“EmailCC”: “”,
“EmailBCC”: “”,
“EmailFromDisplay”: “UDA ASSET TRACKING SYSTEM”,
“EmailReplyTo”: “noreply@appsheet.com”,
“EmailPreHeader”: “Update to application ‘Asset Tracking’ table ‘Asset Master’ by ‘uda.asset.super.user@gmail.com’ at 29/11/2021 14:08:52\r\n[App version 1.000227 is not deployed. All emails are therefore being sent to the app creator. This email should have gone To ‘uda.asset.super.user@gmail.com’ CC’ed to ‘’ and BCC’ed to ‘’]\r\n”,
“EmailSubaccount”: “FreeAccount”,
“EmailSubject”: “ASSET MASTER REPORT”,
“EmailTitle”: “Alert: Update to application ‘Asset Tracking’ table ‘Asset Master’”,
“EmailMessageChannelName”: “System Default”,
“EmailIsDynamic”: false,
“Email Attachment Name”: “Asset Master Full Report.pdf”,
“Email Attachment Archive”: “AttachAndDoNotArchive”,
“Email Attachment ByteLength”: 0,
“Email Attachment FileName”: “”,
“Email Attachment FilePath”: “”,
“Email Attachment MIMEType”: “application/pdf”,
“Email Attachment PageOrientation”: “Landscape”,
“Email Attachment PageSize”: “A4”,
“Email Attachment PDFCount”: 1,
“Email Attachment TemplateHasCustomFonts”: false,
“Email Attachment TextLength”: 4555248,
“AppTemplateName”: “7994bdd9-68f5-4bc9-a5d5-a864761696c5”,
“Operation”: “Change Bot”,
“Result”: “Success”
}

Based on this detail, AppSheet is successfully generating and sending an email to the app creator email address - that would be the one you have logged into AppSheet with.

Since you are not receiving the email, even in Spam/Junk folders, it is likely the email is being blocked as Spam somewhere along its travel path. I recommend opening a ticket to AppSheet to investigate. If the above is true, AppSheet can clear it up.

https://www.appsheet.com/Support/Contact

1 Like

In the meantime, I am noticing these details in the log entry. It seems the attachment is blank. Try sending just a regular email with some text in the email body and NO attachment.

1 Like

Dear Willow, thanks again for the help.

I have try remove the PDF attachment, and ya, I receive the email without attachment.

I am wonder, am I having a huge PDF attachment, and will this causing this problem?

According to the log entries, the attachment is empty. Are you generating the PDF using a template or is this a pre-existing PDF?

2 Likes

Hi Willow, I am generating the PDF using a template.

Thanks for the clue, after read your reply, I change my email PDF as attach & archive.

And found that, the email is still not send, but I found the archive PDF file, the size is about 36mb, I believe this is the reason why I didn’t received the email, as I remember, the largest size that could attached with GMAIL is 25mb.

Thanks you for your help.

PS: Do you have any clue, how can I reduce the generated PDF file?

1 Like

I would test with a smaller sized PDF to see if your suspicion is correct.

This will highly depend on the content of your PDF. If you have a lot of graphics and/or images, then maybe you can reduce the number of those.

If the PDF is mostly data, then it might be best to break the PDF into separate logical parts each being emailed individually.

Another option might be to provide the LINK to the file rather than an attachment. Recipients can then download the file to view it.

2 Likes

Thanks Willow.