Problem with images access rights for a publi...

(StudentHomes Plymouth) #1

Problem with images access rights for a public app.

I’m relatively new to Appsheet and thought I was doing okay with one multi user app deployed and one public app up and running as prototype. Sadly, not working as well as I thought some users of the public app have reported that they cannot see the images just the file path error triangle with exclamation in it.

Problem is I have 200+ images I am displaying and all paths have been entered in a similar manner e.g. Property Gallery_Images/04-18-2018 08-16-20.Image - Property.071646.jpg. At present it would appear that the only way to get them to display for these users is to change the folder rights on my Google Drive to “Public on the web - Anyone on the Internet can find and view”.

I’m very dubious about changing the rights to this, can you confirm whether this is correct or do I need to enter the images in a different way? Does Appsheet manage the access rights for Public Apps or do I need to change the rights on any Google Drive folders the app is using?

My apologies for keep raising basic questions like this and I have read a number of the articles but can’t seem to nail this one. Once I crack the basics hopefully I won’t keep bothering everyone, but for now your guidance on this critical point would be appreciated. Regards, Steve

(tsuji koichi) #2

Did you check the access mode on the table which contains the image column?

I suspect this “access mode” setting might be left to “as app user” instead of “as app creator”

On the app where you don’t require sign in or even it is required, the user will access to the data source by using your (as app owner) authentication, when you set this “as app creator” and you don’t need to share the folder/sheet with your end user by googlesheet setting.

(StudentHomes Plymouth) #3

I’ve checked the various tables in my public app and they are all set to “app creator” so I don’t think this is the problem. Incidentally I also have “shared” set to on. At a loss to know quite what I’ve done wrong but I think my Google Drive structure may be the problem?

Just to be sure I’ve attached a screenshot of my table settings.

(tsuji koichi) #4

@StudentHomes_Plymout Sorry for not helping. I m not exactly sure what the root cause. However, it looks like you are using multiple spreadsheets.

I don’t have a clue, but how about trying to change sync option of Delta Sync ?

It is turned on now?

Go Behaviour

  • offline/sync -

and change Delta Sync to be turned off.

(StudentHomes Plymouth) #5

No need to apologise, thanks for trying. I’m using one spreadsheet with multiple tabs (tables) within it. I’ll look into the sync suggestion.

(Praveen Seshadri (AppSheet)) #6

You do not need to make the folder public. The images should be accessible without that. If you make that change, do the images become accessible?

Please share some of the details (app name, etc) and one of us would be glad to look into it.

(StudentHomes Plymouth) #7

I did change the folder permissions containing the images to public and the user who reported the problem could then see them. I am sure it is something I must be doing wrong. The app is still being tested but I am happy to sign up for Premium plan for public app to get support. Reason being I am also having problems with 3 show images in a Tenancy application form. I’ve followed your help document and video to the letter and cannot get them to appear when a new record is being added. The app name is StudentHomes and owner account is StudentsPlymouth@gmail.com.

For the record I also have a deployed app called “Property Manager” licensed for 2 users under account info@studenthomesplymouth.co.uk which I also have a problem with as it is logging 3 users which should only be 2?

As a new user I appreciate I am probably creating a number of these problems myself and once I grasp the basic concepts I feel sure I won’t need to keep bothering you. I am very impressed with the flexibility Appsheet provides, just need to learn how to use it!

Please let me know if you need further information.