Question with symbols on top of table view form

Screen Shot 2020-04-10 at 2.17.34 PM

I am using a table view to display records to select, one at a time, for a user to make edits and grant approval. There is nothing to edit on this page yet the edit button appears at the top. I have no idea what the square box with a check is for. The search and sync are fine.

Is there any way to hide the middle two buttons (edit and checkbox)?

What you are showing seems odd in several ways.

First the icons:

  • Edit icon - is for table editing and is turned on inside of the table view. You can turn it off if you don’t expect to use it.
  • Checkmark box icon - this is used for bulk actions. It gives you the ability to select multiple rows and then apply an action to all selected rows. This icon only shows when there are valid actions to apply to bulk rows. If you don’t want it to show at all, you could add to the Action expression, code that invalidates (and thus hides) it in a table view.

The Odd Bits

This looks to be a grouped table view. As such you should NOT be seeing those two icons in this part of the view. They should only show up when you have data rows showing - such as when you expand a group.

Also, if this is a grouped view, is it scrolled to the bottom of the list? I would expect to see the “All” at the top.

Is there anything unusual you have coded for this particular view? Just wondering how it might have gotten into this state.

Ok, I found that I had QuickEdit turned on for this table view. I turned it off and the edit button disappeared.

I clicked on the check box and it allowed me to apply the action button that resides on the detail form brought up when you click on a row in the table view. I certainly don’t want that to appear there as the user need to raid through the detail view and potentially make updates before they click on the !st_OK button which sets 3 approval fields. But I do have a confirmation that pops up that would remind the user to check. I’d rather get rid of the checkbox on the table view. Any idea if I can?

Thanks for your help. I would not have figured it out, as far as I have, without your help.

Lucinda

Yes, you can “hide” that action (or any others) for Table views since you won’t be using them there. If there are no actions to apply in Bulk mode, then the Checkmark Box button will go away.

To make this change in you Action(s), go the Behavior section and update the “Only if this condition is true” expression to include:

CONTEXT("ViewType") <> "Table"

Obviously, if you already have something there, you will need to use an AND() function.

Once you have made this change to any of the Actions that are appearing for Bulk selection, the Checkmark Box button should go away.

1 Like

Thank you John. I’ll have to look at that after I finish making and eating dinner.

Lucinda

I went to Actions. Selected this action.
Behavior and put CONTEXT(“ViewType”) <> “Table”
in the Only if this condition is true expression and it did NOT work. The checkbox is still there.

yes, I saved and tried it a couple of times. Any other suggestions? Thanks.

Is it that Action that is showing or is there another one?

It is possible. I have a test table that was showing the icon because it had Delete capability. Once I turned off the Deletes option on the table the icon was removed. If I were to add a custom action for this table, it would show up again.

Screen Shot 2020-04-10 at 7.26.32 PM

It may be that you have to apply the function to all possible Actions in that table which may make this unfeasible. I have another table with many upon many actions and I was not able to get the icon removed.

At any rate, it seems that this feature needs an “off” switch!!

1 Like

I only have UPDATES on this slice since it is for curating/approval of requests.

When I use the AND(TRUE,CONTEXT(“ViewType”) <> “Table”) expression, the checkbox is there and I can select records BUT I CANNOT apply the action. The CHECK to apply icon is not there.

If I switch back to just TRUE, both the checkbox and the ability to apply the action is there.

I do have another action on this slice, but it is just to return me to the table view from the detail view. So I don’t think that would effect this - but my knowledge is very limited.

I really appreciate your help. As I said before, I don’t think I would of been able to track this down without your expertise.

I do wish there were finer controls over some aspects of AppSheet. A lot of my issues are probably due to my lack of knowledge of AppSheet but I think there are some, like this and a few other items I found, that could use better control.

For now, I’ll remove the CONTEXT(“ViewType”) <> “Table” so the user won’t be stuck with having selected records and not being able to do anything after that.

1 Like