R1C1 notation does not get translated to A1 when inserted in Google Sheets?

I have a spreadsheet formula in Google Sheets, that AppSheet detected and translated into a R1C1 formula in the app. Normally, when a new row is added through the app, this R1C1 notation should get translated back to an A1 notation so that it works in the sheet, but for some reason, it does not.

An example of a formula in Google Sheet: =SUM.HVISER(Ordrer!F:F;Ordrer!B:B;B:B;Ordrer!J:J;D:D;Ordrer!X:X)

What Appsheet translates it to:
SUMIFS(Ordrer!C[-1]:C[-1],Ordrer!C[-5]:C[-5],C[-5]:C[-5],Ordrer!C[3]:C[3],C[-3]:C[-3])

This formula is also what is inserted into the cell in the sheet, breaking the formula. I’ve tried regenerating the table but to no help. Any ideas? It hasn’t always acted like this, but I do not know what triggered this change

Best regards

Please contact support@appsheet.com for help with this.

1 Like

I found the issue, so I’ll let the thread stay in case anyone else has the same issue. Apparently some rows had formulas there weren’t identical to the normal formula in that column. Fixing those, so that all cells contained the same formula, and then regenerating the table fixed it

3 Likes

Well done!

1 Like