Regenerate Column & network errors

Hi folks,

Regenerating Column is causing me a ton of issues, so I’m looking for a bit of insight here.

Problem 1) Sync on Start not working?

A user reported to me she’s was unable to add a row to the app because she’s getting the following error message.

Backstory: The day before, I added a new column to the “Moderator_Numbers” sheet. So it seems this error means she was using a version of the app that didn’t have the newly added column, even thought I had “Sync on start” turned on. I thought “Sync on start” automatically syncs the newest version of the app when they open it to prevent this happening. Is this not the case?

Problem 2) Different users, different versions?

My user got this message every time she tried to sync (she still cant get into it). I was able to access the app and use the newer version fine. Her permissions are all correct. I can launch the app as her fine and she confirmed she was online as well. So how is it that she’s unable to sync the same version of the app I’m using?

Problem 3) Table Offline?

I decided to regenerate the column structure of my Moderator_Numbers tables to address this problem . This took over 10 minutes (much too long), and I was thanked for my patience with a whole bunch of scary looking errors.

It’s acting as if the “Moderator_Numbers” table is offline, but it’s not.
Once I refresh the page, the errors go away.
My user’s original message also indicated that it thinks the “Moderator_Numbers” table is offline, but it’s not.

Why is my app acting like my table is offline when it isn’t?

Needless to say, it’s been quite embarrassing to encounter this problem without a solution for my client. So if someone could provide some insight to prevent these issues from happening again, it would be greatly appreciated.

I cant update anything on my app. I am using Google Sheets.

This has been since yesterday (12/3). Cant regenerate tables, change anything in the UX. Just keeps loading and loading.

Tried to do it on many platforms (Windows Computer, Ipad, Android Phone, Mac Desktop) using google chrome.

Update:

Seems to be a Chrome issue for me. Just tried Opera browser on my android phone and am able to regenerate columns.

@cr130 same issue happens with me on Safari & Chrome