Remove a entered item from a dependent dropdown list

Hi I have a app with that uses a dependent drop down list of raw materials to complete a bill of materials. However, the users find that it can be difficult to keep there place when selecting the raw materials.

Is there a way to remove an item from the list once it is selected ( I thought I saw a post detailing this before but I can find it)? The Raw materials table are ref to another table as well.

@Elijah_Magrane
I don’t know your expression for creating the dependent dropdown, but you can try this expression in your Valid_if

TableName[ColumnName] - SELECT(TableName[ColumnName],[ColumnA]=[_THISROW].[ColumnA])

Hi @LeventK ,

I think some more details would help. I have three columns, [Product], [Flavour], and [Ingredients].
The product and flavour columns just use a simple [{ref_column}].[{lookup_column}] app formula. While the Ingredients column uses a traditional valid_if TableName[ColumnName] from the lookup table

I have tried the formula you suggested as follows but no dice…Production Details[Ingredient] - SELECT(Production Details[Ingredient], AND([Production Id]=[_THISROW].[Production Id],[Product]=[_THISROW].[Product],[Flavour]=[_THISROW].[Flavour]))

The expression resulted in filtering out the relevant list. I hope this extra info helps. Cheers

@Elijah_Magrane
What the name of the table that you have that 3 columns (Product, Flavour and Ingredients), what’s the table name of your lookup table that you use for the [Ingredients] column? Which one(s) is/are your ref column(s)? What’s the ref table name? etc.etc.

Hi @LeventK

[RM Verification] -this is the table that has the ( Product, Flavour and Ingredients ) columns

[Production Details] Lookup table

[Production]- this is the main Ref table See here

@Elijah_Magrane
You can try with this:

SELECT(Production Details[Ingredient], AND([Production Id]=[_THISROW].[Production Id],[Product]=[_THISROW].[Product],[Flavour]=[_THISROW].[Flavour])) - SELECT(Production RM Verification[Ingredients], AND([Production Id]=[_THISROW].[Production Id],[Product]=[_THISROW].[Product],[Flavour]=[_THISROW].[Flavour]))
1 Like

@LeventK Thank-you, Thank-you. That worked perfectly. Much appreciated.

You’re welcome @Elijah_Magrane.

@LeventK Hopefully, a quick follow-up . I tried using the same formula in a very similar app structure but I am having problems getting it to execute.

The expression is SELECT(Production RM List[Ingredient], AND([Product]=[_THISROW].[Product],[Flavour]=[_THISROW].[Flavour])) - SELECT(Production Details[Ingredient], AND([[Product]=[_THISROW].[Product],[Flavour]=[_THISROW].[Flavour]))

The structure is fairly straightforward…
Production RM List is the lookup table
and Production Details[Ingredient] is the table I am trying to filter

Any help would be appreciated

@Elijah_Magrane
Couldn’t understand the problem. 2 posts above you informed that it’s working, but you now say that it’s not working? Can you elaborate?

@LeventK
Sorry for the confusion Ill try and be more clear.

My last post is referring to essentially the same formula in a different app. It is odd because the App structure is very similar to the previous on that you helped me with.

Here is a gif of the NEW app that I am working on and the issue that I am having…

@LeventK wasnt sure if you saw my above update. Complete with gif

Still can’t figure out why the app is behaving so differently. I have tried a bunch of different variations with no luck