Remove Column from Detail View

Hello AppSheet Community :slight_smile:

I have tried everything I know how to do to remove the long stops column from view, but toggling “Show?” to OFF will not make it disappear from the Detail View. How do I omit the long list in the picture? Thank you very much.

-Tiffany

Here is the SHOW IF formula I am attempting:

Please try the expression as

AND(CONTEXT(“ViewType”)=“Form”, CONTEXT(“ViewType”)<>“Detail”)

2 Likes

Per @Suvrutt_Gurjar, it’s detail (singular), not details (plural).

2 Likes

Is this setting also need to be ON?

or will the CONTEXT expression above is sufficient?

1 Like

Yes, that setting must be ON.

2 Likes

I tried exactly this and nothing changed. :frowning: I don’t know what’s going on.

Perhaps you’re targeting the wrong column?

image

I changed the display name of the column. Products appears as Stops.

1 Like

Could you please repost the screenshot of the new expression?

2 Likes

1 Like

Thank you. In that case could you please try an expression something like below

CONTEXT(“ViewType”)= “Form”

Thank you for your help @Suvrutt_Gurjar, @Steve and @Heru. The problem was the Apply show-if constraints universally option. When I toggled it to on the problem was solved.

3 Likes

Hooray! :slight_smile:

2 Likes

@Steve @Suvrutt_Gurjar @Heru
Is this a new/recent property? I don’t remember seeing this before this post.

It’s been a part of AppSheet as long as I’ve been using it.

1 Like

Oh great! Now I have to question the state of my mind! :woozy_face:

4 Likes

Serves you right after munging my understanding of Editable?:confounded:

1 Like

To share my test when try to reproduce this post:

I saw a behavior that even by making Show? to OFF, the column still showing in a detail view (See#1 and #2 in picture below)

The column type is TEXT, a Virtual Column Type.

Column is hidden ONLY after Apply-ShowIf-constraints-universally to ON (#4)

It does creates some confusion around when Show? is OFF but apps still sees the column.

Maybe it behave like this because of column is a virtual column?

The column in my particular situation was NOT a virtual column.