Reports not running

Hi all,

I’m having an issue with my reports not running. I had downgraded my account in August 2019, which was the last time my reports ran.
I just redeployed the app. And am trying to run a report using the run function. The run activity shows in the audit log as successfully completing but it’s been 10 minutes and the emails have not come through.

I’m also not seeing any error reports on the report content or expressions.

Any ideas?

Update: 12 hours later - no reports - 3 run attempts - no errors on the error log.
I’ve tried deleting and reattaching the reports to force another expression review on save.
But there are no errors being reported from my data.

Perplexed!

Do you have the correct email in there?
Do you have a condition set in the “If this is True” section?

Thanks Jonathan,

I’m using the USEREMAIL() function and asking the system to send the report to all participating learners (a data slice).
I just double checked and it looks like the expression was turned off by default.
I believe the report interface changed between August and May, so I missed that update.
I’ve turned it on now and tried resending but so far no joy.

e

Resolved!
I had some minor errors in my column names/expressions.
But the error warnings didn’t show up until abou 14 hours after I made the errors.
I wonder if this is because I turned on server caching.

e

3 Likes

Great :smiley: