Restrict access through specific sql ports?

We’d like to connect appsheet to a sql server - can we restrict on ports also? I see this below…

1 Like

Similar issue for me. I see there’s a long list of IP Addresses we’re required to give access to. But is there a particular port??? Hopefully someone from appsheet can provide some clarification

I spoke with @Scott_Haaland yesterday. They are updating the documentation, but you can restrict on standard sql ports (1433 i believe)?

1 Like

Here is the doc with that reference to the standard 1433 port. If you are using a non-standard port, then you would need to use that in your firewall rule, and use the , syntax in your data source config, like:,2000

(search on for SQL server port and it comes right up)



Thank you @Scott_Haaland for the update and advising this to us Community.

I wondered if this can be applicable to other SQL instances like MySQL, Postgres and others. Just add the port number after the server name split with comma? Or this is only to SQL Server?


1 Like

Scott - we completed the networking items. To build the connection to on-prem, without using DreamFactory, do we choose the cloud database option, even though it is on-prem, but opened up to appsheet?

When we choose On-Prem, it only shows the dreamfactory option … So, we were able to authenticate, but got this after clicking “authorize”…

The URL was: /Account/addsource?csrf=uFGgwBFKBeFUi1gv6znYMCa8uTVyB3OBb4hufcYKLcSNBgqLAI7GadWqaZcuf5D9j9X8-7PAmB_6rT6_7FmnnIjcYVgc9hsz3W0aVbpH6_5oszWlW9czWfDHgwp-vfE5Kh9iI1sylwzOX02JQnNAvQ2&domainOnly=False&externalFailure=A%20potentially%20dangerous%20Request.QueryString%20value%20was%20detected%20from%20the%20client%20%28code%3D%22…word%22%3A%22%5E%5DB%

any ideas?

to clarify, we had to go:

Cloud > connect to on prem > click test…authorize button opens up…then get that error…

Am I missing an option?

I see this thread, I might hop over there to combine these:

Hi Matt,

If you open a hole in the firewall, then you would still choose cloud database. The on-Prem DB option only works through DreamFactory today.

Sorry for the confusion. In essence, when you open the firewall, AppSheet now thinks it’s a Cloud DB since it can via a network from the cloud.


Hi @tsuji_koichi ,

I was trying to track this down with Engineering, but it looks like the comma port option is only available so far for SQL Server.


Hi Scott,
Thanks you for checking this for us. Sure, that s fine.