Rows that don't meet filter criteria still appear in slice

I have a slice that is showing rows that should be filtered out.

image

If I click Test next to the expression for the row filter condition, these rows display N, which should mean that they should not appear in the slice. But they still appear in the slice.

To test further, I created a virtual column with the same expression as the slice’s filter condition. I can see right in the table view of the slice that these rows are returning false, but they show in the slice anyway. How can I troubleshoot this?

image

This appears to be an issue/bug with filtering a File column type. I have successfully worked around this bug by creating a new virtual column that converts the File column to a text column. Filtering against the new virtual Text column works as expected.

What if you just wrapped [File] in TEXT() in your row filter condition expression?

That’s a great idea and I hadn’t thought of it. Just tried it and it doesn’t work, though.

I’m guessing there’s some kind of encoding of the File column type happening on the backend before it gets evaluated against these conditions.