Run automations from data in Google Sheets?

We just updated the primer to version 1.1. This has a brand new use case that allows processes to be triggered from data in Google Sheets. Please check it out and let us know what you think!

2 Likes

It works when I run it from the app, It doesn’t work when I enter directly into Google sheets. I’m not sure if it’s supposed to, but here is the error message…

from the Google Apps Script Execution history, I’m getting this when I add to my leads or “contacts” table.

{"Message":"No HTTP resource was found that matches the request URI 'https://www.appsheet.com/api/v2/app-events?type=ADD'.","MessageDetail":"No action was found on the controller 'PublicAPIV2' that matches the request."}

I generated a new api and used the table name at the end of it…

Jan 4, 2021, 1:01:09 PM Info whenEdit function called
Jan 4, 2021, 1:01:09 PM Info {“authMode”:“FULL”,“range”:{“columnEnd”:7,“columnStart”:1,“rowEnd”:3,“rowStart”:3},“source”:{},“triggerUid”:“5788092”,“user”:{“email":"corpitappsheet@gmail.com”,“nickname”:“corpitappsheet”}}
Jan 4, 2021, 1:01:10 PM Info {“data”:[{“First Name”:“Matt”,“Last Name":“Brown”,“Email”:"mbrown3@ebsco.com”,“Company”:“EBSCO”,“Date”:“2021-01-04T06:00:00.000Z”,“FollowupRequested”:“Y”,“FollowupAfterDays”:10}],“tables”:[{“api-key”:“V2-VKbyn-s3J91-6as5j-hCJoM-yMCBE-EkWkP-6qXu1-5vSR9”,“table-name”:“Contacts”,“schema-version”:“1.0”}]}
Jan 4, 2021, 1:01:10 PM Info https://www.appsheet.com/api/v2/app-events?type=ADD
Jan 4, 2021, 1:01:10 PM Info {“Message”:“No HTTP resource was found that matches the request URI ‘https://www.appsheet.com/api/v2/app-events?type=ADD’.”,“MessageDetail”:“No action was found on the controller ‘PublicAPIV2’ that matches the request.”}

Hi Matthew. The add-on needed to make this work has now been released. It can be accessed with this link: https://gsuite.google.com/marketplace/app/appsheet_events/592572205846

Please install that add on, add your API-Key, and try again

Does this look right? i see a lot of x’s

does the api key still need to be the key from the app + table name?

Hi Matthew,

The API Key is now just the key by itself. it should be in a form similar to: V2-7Dtmy-XXXXX-XXXXX-XXXXX-XXXXX. Your key seems to be in a url format; this should not be the case. It should be the key from Manage > Integrations > IN: from cloud services to your app. You should enter the complete key (unmasked), and it will be displayed in a masked form.

Temi

1 Like

Ok, thanks Temi. I have the correct key now.

I tried to update the key but the add-on doesn’t seem to allow it.

I removed it, reinstalled, but do not see it anymore in the add-ons (just the normal appsheet add on). Is it a delayed install?

Hi Mathew,

You shouldn’t have to uninstall the add-on. Your should be able to delete the key and add another key. Also, if you uninstall and install again, the add-on should show up immediately after you refresh the google sheets window.

One thing to note is that even if you re-install, the bad key will still be there, so you will need to remove that key and add the correct key. Please let me know if you are still having issues after that.

Thanks,
Temi

Ok, thanks Temi - It is working.

My issues was - I have 3 google accounts. One is a gsuite and it was trying to do a domain install.

I went to incognito and it worked better.

After that, worked perfectly.

Awesome! Glad to hear it!