Sample app not on portfolio page but accessible as sample?

Today I found an old sample app of mine via a Google search. It turns out that I had left the sample setting on . . .

Screen Shot 2021-02-24 at 22.11.55

. . . but turned deployment off:

Screen Shot 2021-02-24 at 22.12.06

The sample address is as follows:

https://www.appsheet.com/samples/Kankaku-is-a-spaced-repetition-app?appGuidString=0f0c2547-2b54-4bb4-87e2-a015636b6b24

Here’s my question: If I give people a URL like the one above of an app that continues to be a sample but is not deployed, can I expect them to be able to copy it without a hitch? I just tried logging in to another account I have and copying the sample from the URL you see above and it worked.

If I can confirm that I can do this and that I can expect to be able to do it in the future (i.e. it’s not an “unsupported” method) it will be useful for me because I don’t want to clutter my portfolio with too many apps but sometimes I want to share a little sample related to something we are discussion on this page.

1 Like

As I wrote above, this worked we I tried it above so if there are no objections, I think I might like to post this as a tip instead of a question.

1 Like

Thanks for asking this question.

I would call this as a bug… Logically stange, aha?

Unless we deploy the app with sample app setting being ON, we are not able to generate and share sample app. In that context, pushing back the app status to prototype, the sample app should be gone from the eyes of public.

I also tested with my app. Yes, indeed you are right. After pushing app back to proto, the given url still alive, and we are able to access to the app as it .

Then question is how to remove the public sample from anyone? Once we give a birth, then no way to kill it out…

For me, i now understand we are not able to remove the sample app from the public untill we turn off SAMPLE APP setting, or completely delete the app.

3 Likes

I probably need to correct my previous words.

I just tested further.

Turned off sample app setting.

BUT

Still we are able to access to sample app from the given URL… It is possible my account info being cached to browser is doing something wrong, but i asked my colleague to do the same test. Indeed, even PROTYTYPE + NOT SAMPLE app can be accessed to this sample app…

Then now questiion is boling down to how to withdrow sample apps once they are deployed?

3 Likes

Interesting. Thanks for checking. If you have the url of the app that is no longer a sample but you could still access, I’ll give it a try if you send it to me in a private message. When I was testing my own app last night, I think I was relogged in automatically so testing by myself was difficult.

Actually, I LIKE being able to have an app that I can share only with the URL but keep off my portfolio page. I hope the option will remain.

1 Like

"SAMPLE APP FOREVER SYNDROME"
(サンプルアプリは永遠に症候群の件)

Easiest check if you never mind is to give URL for KANKAKU-V6 sample page, after you made sure the app status is prototype and then the sample app setting is OFFed.

Could you share the URL ? ( i know you shared with us on the first post of this thread)

I could access to kankaku sample page.
But wish to test what happens once you pulled it from sample and with prototype mode.
Likely we will be able to access to it.

2 Likes

Done. Actually, this is so old that I prefer to turn the sample off. :slight_smile:

Screen Shot 2021-02-25 at 14.28.07

1 Like

This is good. Now i m not able to access to the sample app page for Kankaku V6

But my mistery continue on my own case…
Even after I turned off, still the page is alive… I will continue to test.

1 Like

I just tested my own link on my end and got the same result (404 - etc). I wonder if switch to a different account (which is what I did – not just logging out) is necessary. If I’m logged in with the account I used to make the app, I can still access it:

Could that be the cause of your issue?

1 Like

Possibly… The login detaile being cached to the browser could be doing something wiered.

I just sent private message to you, Sensei.

Koichi

Separated issue.

I hit link to your portfolio page, it takes almost 3 to 5 mins to render the page…

Still the problem seems to be prevailing…

Access to my own portfolio page, the same problems. Super deadly slow and heavy.

3 Likes

Actually, I looked at your portfolio page yesterday and it didn’t seem to be quite that slow. I hope, though, that the problem can be resolve.

In regard to the ex-sample (“sample” setting turned to off), I was just able to view it, though I got the following error when I tried to copy it:

Screen Shot 2021-02-25 at 15.02.17

But, I was able to play with the app and change the data!! (Sorry, I hope changing the data isn’t a problem for you – just did it as a test)

Screen Shot 2021-02-25 at 15.03.03

You are adding more pains over me!!! Stop it!!! haha.

Yes, that is sample app i privately shared with you, and data is dummy etc, so you can mess them up! NP.
But another mystery comes up. Why can you do that?

Will contact appsheet support later once the desk opens today.

^ _____OoO
ミ・。・ミ
KT

2 Likes