Schema Error when adding Collection of files

I am receiving an error when trying to add a table as a Collection of files. (screen shot below)

The folder called ‘Report Files’ is on a shared Google drive. This same drive is where the application’s data sources (Google Sheets) live, and I have an automation that is creating PDFs to the drive, as well. In other words, I believe the access and permissions are OK.

It seems that these errors are telling me that it can’t see the schema for the table/folder, but I’m not sure how to address this since I believe the permissions to be correct.

Also, I have confirmed that the DocID for the folder shown in the error message matches the folder’s actual DocID.

Any thoughts on how to address this? Thanks in advance!!

Hi John and welcome to the AppSheet community!

Let me see if I can reproduce your situation and get to the bottom of this.

Thanks!

Thank you! Let me know if I can provide any additional info.

Quick question. Is this a repeatable error? By which I mean, if you remove the folder backed table and then add it again does it generate the same error messages?

Yes, I’ve tried it multiple times, same result each time.

Some additional info on this.

  1. I tried adding the same folder as a table in another app and received the same error.
  2. I tried adding a different folder as a table in the first app, and this was successful.

The folder that fails is on a Google Shared Drive, the folder that was successful is in the app creator’s My Drive. Should this make a difference?

Thank you - John

Thanks John,

I suspect that is the issue. I am looking deeper into this and will let you know when we have an answer.

Hi Philip. I know you guys are juggling a lot right now, but I just wanted to touch base and see if you have an update on this, or if I can provide any additional information.

Thank You!

Hey John, thanks for checking in. We have identified that shared drives are not properly supported at this time. We have an open item to fix this. I will update this thread once it is live.

1 Like

Shared drives are now supported for document based tables

1 Like