Setting up a device to use the app in Appshee...

(Joseph Pentheroudakis) #1

Setting up a device to use the app in Appsheet with user credentials (not editor)

(Note: I piggybacked on a separate thread for this, and in the end I figured out how to get around the problem, so I’m posting here as well in case someone knows why this happens. I may have missed it in the documentation.)

My app is now deployed (yay!). We will have one editor (me) and one user account (for our field crew). The field operator will be using the app as a user on an iPad. We have two iPads; the second one is just a backup. Only one device will be used at a time.

After deploying the app and shared it with the user account. The user account is allowed edit access to the Google spreadsheet on the backend.

I downloaded the Appsheet app successfully on both iPads, then tried to sign in with the user account credentials.

That’s where I hit a snag. I couldn’t see my app even though I had signed in successfully with the user account credentials. The app thought I was signing in as an editor, ready to create a new app. My app didn’t appear anywhere in the App Gallery.

Here’s what seemed to fix it:

  • I logged out the user from the Appsheet app on the iPads. - I logged back in as the editor, again on the iPads. I was able to see the app, so the problem was not with the device. - I logged out the editor from the iPads. - I logged back in as the user. This time I was able to see the app as a user and it all looks lovely.

Now for the Big Question: why did this happen? Is logging in as the editor first required for initial setup of a new device? Are there settings I missed somewhere?

(Tony Fader) #2

+Charlie Wells The best way to get your app installed and runnable for your users is via the “Share App” link in the editor. There you can add them as app users and optionally add them as co-authors (which will allow them to edit the app).

(Joseph Pentheroudakis) #3

@tony of course that is exactly what I did. It’s just that I had to sign in first as the author, sign out, and then they could sign in. They could not sign in unless I did that first.

I’m not making this up :=)

Thanks!

(Tony Fader) #4

+Charlie Wells Logging in as the editor in the app is not required. It could be just a timing issue. Does the same thing happen to you if you repeat the same steps with a different app?

(Joseph Pentheroudakis) #5

Thanks @tony. Timing: oh, good suggestion.Maybe the app connection to the AppSheet servers times out? I did try several times with the user account and failed each time, and again the only thing that seemed to work was going in first as the editor and repeating the steps I mentioned. Logging in as an editor never ran into a connection problem, so maybe the connection timed out to whatever resource that user account info is stored? The Google portion of the sign-in was fine (I got the alerts on the editor gmail account).

Anyway, I know how to work around this now, I’ll let you know if I run into similar problems again.

And no, I don’t have any problems signing on to other apps.

Thanks!

(Joseph Pentheroudakis) #6

@tony and here’s a thought. Is there a limit to how many devices a user can be signed in on? if so, do you keep track of IP addresses? Maybe the IP address of the user device was blacklisted until the editor signed on? Just thinking out loud here. No need to reply… Thanks again!

(Tony Fader) #7

+Charlie Wells A user can use your app from up to five different devices. We don’t do IP blacklisting so that’s not the problem.

FYI, the pricing page has information about how we count users: appsheet.com - App Maker Pricing - AppSheet

Let me know if the problem repeats on your next app :slight_smile: App Maker Pricing - AppSheet appsheet.com

(Joseph Pentheroudakis) #8

Awesome, thanks @tony. That all helps.