Should a bot that runs a change-data action work the same as that action triggered in-app?

I’m trying to do some looping to create grandchildren records without control columns, pretty much exactly as in this post.

If I run the group of actions in-app either as the form save action or triggered by a button, it works as expected (i.e. it creates a finite number of grandchildren records). If I run the exact same group of actions in an automation bot, it results in what I presume to be an infinite loop, adding the same row over and over until I delete the target table and it errors out.

  • Minimal reproduction/Sample app
  • There are a couple of actions on the grandparent that, for each parent, create one child per aunt/uncle: one grouped action to accomplish this in-app, and another to trigger a bot to run the same grouped action. Tried to make it as simple as I could, but now having written that out I probably could have chosen better terminology. Hopefully it makes sense…

I’m wondering if it relates to this issue…something to do with SELECTs in an automation bot? Or maybe this nugget as the exit condition of the looping action might be considered intermediate state and thus not to be relied upon?

I’m aware of a few other ways to accomplish the same thing, I’d just like to know if this is a bug or if I’m missing anything obvious before I sink any more time into this approach.

2 Likes

Unfortunately I have been using the same with workflows in my production app and automation does not support this. I have no idea how it would anymore other than actions on save. Hope some good news will be in our favor.

1 Like