Show/Hide Column with Formula

Is it wrong to expect that a formula in the ‘Show?’ attribute of a column can drive the visibility of the column?

I have a column where the formula specifically returns ‘FALSE’, but the column still shows in the ‘Detail’ view. I’m perplexed…

Colunm [SpanishWords]:

  • View: Listed as a column to display (in ‘Column order’)
  • Data:Show?’ attribute is the default unchecked checkbox in the table

As expected, the column does not show up in the view because of its visibility settings.

Colunm [FrenchWords]:

  • View: Also listed as a column to display (in ‘Column order’)
  • Data:Show?’ attribute is the formula ‘FALSE’ in the table

Surprisingly, the column shows up in the view. I was expecting it not to because it’s visibility settings is ‘FALSE’.

Note: I used a simple ‘FALSE’ formula here to illustrate the example. I would normally use a more complex formula, based on user roles for instance.

Here is a screenshot:

I wonder what the formula can be used for if it cannot actually drive the visibility… Any insights?

Thanks!

1 Like

Could you please check the below setting?

4 Likes

That was it. Many thanks @Suvrutt_Gurjar !
Working like a charm now. :grinning:

2 Likes