Show the header as a data

It happens in all UX views (Deck, Card, Table,…)

When I haven´t any data, it show me the view with the headers.
When I create the first data, it disappears.

I try to change. UX / Options / Show headers and It doesn´t work.
I try to change. UX /Options/ Apply show-if constraints universally and it doesn´t work.

Any idea??? Thank you.

Please post screenshots showing the headers displayed and not displayed.

1 Like



Show you the spreadsheet

Thank you for your help.

No show headers

Show headers

image

1 Like

But Deck view options does not exist.
Or… I missed.


It think it is not a view problem


Here it is the spreadsheet (by google)

True! The option exists only for table views.

Ah! My guess is that some recent changes to table views have removed the option to hide headers, despite the availability of the configuration option.

@Arthur_Rallu, can you speak to this?

I have created a new table and I have the same error
It may be a version error.
In the previous version I had no problem.

Can I force the system to use an old version?

CHECKED,
THERE IS A BUG IN THE NEW VERSION

I have created a new spreadsheet, only with two column id and test
imagen

I have generated the app
imagen

Repeat the header as if it were data.

As soon as you enter data, it disappears
imagen

1 Like

The header row should be in bold. Do that, the regenerate the column structure in the app editor.

See also:

No changes.

I created a new app with a new spredsheet (with headers in bold) and no changes.

image
image

I am testing to create a slice with a filter
[TEST]<>“TEST”

Can be a solution?

The app screenshot shows a card view displaying one row. The spreadsheet screenshot shows a table with no rows. The two screenshots do not appear to be related.

True, but the app is reading this spreedsheeet.
I don´t know how to change it.

I haven´t any data in the spreedsheet, as soon as I have one row with data the bug dissapears. But if I haven´t any data the app show the headers as a data.