Showif field when form is equals xx

What ShowIf expression should I use when I am trying for a field to not show when is being displayed on a specifically named form?

Please explore if the following expression helps to hide the filed in a specific form

CONTEXT(“View”)<>“Your Specific Form View Name”

Or another expression as follows

NOT(CONTEXT(“View”) =“Your Specific Form View Name”)

2 Likes

My form name is “Order_Details_Form” it only works when I use this (which is the opposite):

CONTEXT(“View”)=“Your Specific Form View Name”

Just to be clear I want the field NOT to show when in “Order_Details_Form”

Thank you.

With the expression

CONTEXT(“View”)=“Your Specific Form View Name”

, the field will show in that particular view. If you wish the field not to show in a praticular view , then I believe , you need to use an expression

CONTEXT(“View”)<> “Your Specific Form View Name”

that’s what is strange if I use <> it does show on that view, but if I use = it doesn’t show

This is the field

This is the form (and the field not showing on the form)

Thank you.

I am sorry.I am unsure why this could be happening. Someone else may have more insights.

You need to turn ON setting to Apply Show If constraints universally.

1 Like

Good catch @Heru. Sometimes one misses basics :slight_smile:

I recollect, in recent another post we had come across the same issue and there also you had suggsted this :slight_smile:

1 Like

I hope this is the same… will require more detail information if the setting already on.

Only to apply Show_If outside of forms. Show_If always works in forms. This poster is asking about forms.

1 Like

Your form name appears to be Order Details_Form (no _ between Order and Details):

image

Please adjust the expression accordingly.

4 Likes

I can’t believe you catch that! great eye! that was it! thank you!!! here is the image of the form name to confirm.

Thank you guys!!!

image

3 Likes

Steve, Great catch as usual. :slight_smile:

2 Likes