Showing blank fields in detail views?

I have a particular system-generated detail view that I’d like to have the headers of columns show even if the data is blank… How can I do that? By default only “filled” columns show, don’t see an option to change that…?

Try setting Show? to the expression, TRUE:
image

1 Like

All the columns are already set to Show=True. The problem is the system generated Detail view. This is a read-only table so this is what folks will see, and only the “filled” columns show… I’d like all columns to show, even if their data is blank, so that folks can see what’s “missing”. Thanks!

There is a difference between setting the Show_If expression equal to TRUE, and simply turning the Show? switch to ON. Which one are you actually doing?

1 Like

The Show? Switch is ON. Really, changing the switch versus saying =True yields different results? I assumed it was merely a GUI version of the same thing. That’s kind of unfriendly.

1 Like

Correct.
I agree it is a bit weird, and not well-documented, but very handy nonetheless once you understand its workings. There are some other similar instances, like setting Editable_If to FALSE, disallows any user editing, but still allows the app itself to make edits (via actions or whatnot).

2 Likes

Does there happen to be a way to add the “=True” in bulk across many columns? I have like 100 of these I need to do this to.

I’m afraid not.

1 Like