# sign not saving in file name

I’m having some trouble with # signs in my file names. It’s supposed to be “Unit #2 Well 121 McKinstry Rd Report 399.pdf” but the # is replaced with a dash.

I have another app with the exact same file name prefix formula but in a save file workflow rather than a bot, and it seems to work fine.
“Unit <<[Crane No].[Crane No]>> <<[Location]>> Report <<[Inspection No]>>”

My columns are all set to Text (in app) and Plain Text (spreadsheet). Any ideas?

I would recommend against using that symbol in a file name. I personally only ever use dashes and underscores, not even spaces, but that’s partly due to a lot of time on a linux/unix bash terminal on my part.

It seems like some developer at Appsheet would also recommend against it and has wrote a bit of code to replace it with a dash. This could be just a pre-caution on their part, or a necessity for some other system that cannot accept those symbols.

The above is just educated speculation on my part. I’d assume the only definitive answer you’d get would be from someone within Appsheet. You could try support@appsheet.com for this one I think.

2 Likes

Can you manually create a file with a name that contains a hash sign?

I agree with Marc on this. Spent my whole morning dealing with what seems to be issues with + in some of our appsheet file names. No definitive pattern was found but removing just a + fixed 95% of the files. We will be attempting to replace everything with dashes and underscores.

3 Likes

Thanks for the replies. This is hard to explain, but the way the number sign is used is actually as a name/description rather than an actual number though so it is preferential to keep it this way. That’s why I haven’t just added the # as a permanent part of the file name. My client has a set of customers whose cranes they inspect. Sometimes the cranes have actual unit numbers, and other times they use a descriptor, like the above, where they are saying that the crane belongs to the #2 Well. These descriptions come from their customers so changing them isn’t really an option.

Is there any reason why this is working in my other app where I’ve used the old workflow/save file method, but it doesn’t work with automation? EDIT: I am mistaken, it’s another field I’m thinking of that isn’t part of the file name.

Is there a way I can change the # to a - for writing the file name to the column so it matches how it’s saved in Drive?

@Austin_Lambeth, are you saying the behavior has changed? That special characters used to be allowed but now are not?

Here’s what I did instead. In the app they can still see and use #. For saving and writing to the file name I went with this.

CONCATENATE("Unit ", SUBSTITUTE([Crane No].[Crane No], “#”, “No.”), " ", [Location], " Report " [Inspection No])

1 Like

Cannot say with definite certainty. If we change the file name and leave the plus they wouldn’t work and if we removed the plus they would work. But we at the same time have plenty of other files with +'s that work just fine.

1 Like