Signatures in PDF attachment workflow I am t...

references
(Sebastian Alvarez) #1

Signatures in PDF attachment workflow

I am trying to make a sign-off sheet with AppSheet that emails me a PDF of the completed sign-off sheet with everyone’s electronic signature.

I’m having issues with signatures now showing up correctly in a PDF email workflow. I reference the signature column in the Google Docs template, but the signatures show up more like a link than an actual image (Picture attached).

I read that you can use Other Attachments for signatures but I would like signatures to be in the document.

Does someone know how I could fix this?

(Praveen Seshadri (AppSheet)) #2

That’s odd. Are you sure the column type for the signature is Signature and not URL?

(Aleksi Alkio) #3

Is it possible to show the link what it is?

(Aleksi Alkio) #4

You’re welcome

(Sebastian Alvarez) #5

@praveen I checked and the column type is set to Signature not URL. The Signature populates in google sheet as “Signatures_Images/07-02-2018 16-12-56.Signature of Awareness.091312.png”

(Sebastian Alvarez) #6

@Aleksi_Alkio This is the weirder part, when I click on the link, it opens up a new tab with the title “fsimage.png” and the whole page is dark, with the signature barely visible in the center.

(Aleksi Alkio) #7

In your original post you mentioned it showing a link instead of image itself. What was the link? And… if you open the image from Drive, is it normal signature image?

(Sebastian Alvarez) #8

In the original picture of the issue, you can see a dotted gray box in the signature column. That is a a clickable link that will take you to the

new tab with the title “fsimage.png”. If I open the image from Drive it is a normal PNG file that has the signature with a transparent background. I did however move the file location, but it looks like it is still referencing and saving it in the new location. @Aleksi_Alkio

(Aleksi Alkio) #9

When you moved the image location, it’s probably reading the image from the cache. If you have moved the image from the original folder, you should change the file name(s) as well. Otherwise the app won’t find it.

Are you seeing this behvior with all of your images or is it just this one? What happens if you try to add a new signature into this record?

(Sebastian Alvarez) #10

@Aleksi_Alkio Hello, This morning when I tried to add a new signature, what it did was create a new folder instead of saving in the moved folder. I tried to move the folder and it worked initially and then resulted in the same issue. I then went into the “FolderLocation” and pointed it to the moved location, and it seems to be working fine now that I told it where the folder was located.

In my experience, it would be more convenient to have the default Images/signatures/files folders to be saved in the AppSheet folder in Google Drive (appsheet/data/“app name”), and not in My Drive. This is why I moved it in the first place and had the issue.

From what I saw the root cause is this issue, was that I moved the folder to a different location. Once I wrote the FolderLocation the issue seemed to go away.

Thanks for your help!

(Aleksi Alkio) #11

The app will save those images etc. depending where your gSheet is. If it’s in your root folder, it will do that. If you move the gSheet into your Appsheet/Data/Appname/ it will work as you described.

(Sebastian Alvarez) #12

@Aleksi_Alkio That is great to know! Thank you for clearing that up!