Simple virtual column in read only table with delta sync on takes minutes to update

Hello ,

I have

-a read only table (with delta on,and no security filters applied) , with one column, and 100 rows. The one column contains numbers from 1 to 100 , representing Order Numbers.

-an Orders table, with multiple column, one of the columns being the order number (not a key column).

-a slice that represents Open Orders , with less than 10 rows in result.

-a virtual column in Order Numbers that lists the Open Orders numbers , with some simple Open Orders[number] formula.

This VC does not update instantly and it even takes quite a few minutes to do so.

Is this a recent behaviour change , VC not being processed instantly for read only with delta tables? Is this intended or a bug?

I noticed in the performance monitor a property “not modified: true” for my read only table .

I tested the same formula in a more than 10000 rows table that is not read only. It works just fine, taking less than 5-10 secs.

Thank you.

Edit : i used the same approach a lot of times in the past , for stock inventory, etc ,with succes.

This week, I noticed the same thing in another app : the VC (simplest if or ifs formulas) does not compute at all in a read only delta sync table. Tested with a few Pixel 5 phones , and in app preview as well.

Does anybody else noticed this issue ?

I’ve asked about this internally. The issue seems familiar to me, like this is expected behavior. I suspect the fix will be to disable delta-sync.


Thank you.

It’s a pity to lose delta sync advantages, it’s useful for large tables.

In one way, with this recent behaviour it’s almost like the delta sync applies to the virtual column too.

In another way, it’s (it was) common knowledge that VCs are computed locally every time.

And strangely , VC seemed to compute just fine in chrome(windows) and some devices , but not in others

I did not find the common nominator for this issue.

Could it be the server caching s fault? I use both delta and server caching.

1 Like

It could be. That, too, sounds familiar.

Hopefully someone will respond to the question I asked internally. In case not, you might be well served to contact Support. They might have an easier time getting the question answered.


The internal response I got about this was, essentially, that the behavior is unexpected. Please contact Support for troubleshooting.




Hi. Can you please help me with an inside look up? I opened a ticket to suport on 31 july. Thank you

1 Like

Ticket found and escalated.


Thank you for your help.

The initial observations are now confirmed by support staff : “either sever caching or delta sync could cause virtual columns not to update on sync” .