Slice Filter Expression Help

Hey Appsheet community!
I’m attempting to create a slice that filters out rows to only include a specific “Date.”

Setup:
2 Tables.
Table 1: Titled Meeting_Topics (Key = Topic name, has a column titled “dates” that has a list of dates inside of it. (i.e. “2/23/2020 12:00:00 AM,2/24/2020 12:00:00 AM”))

Table 2: Is a form that references Table 1 as an enum.

Goal: Create a slice to filter to only show the “topic name” that contains today’s date in the “Date” Column.

Current setup that doesn’t work: in the Slice Row filter condition, i have, “CONTAINS([Date], Today())” .

When I test it, it has a “Y” next to the correct topics. But when I look at the slice as a Table view or as a reference in the table 2 form, it shows up as blank.

Thanks for your help!

What does that mean?

Perhaps IN(DATETIME(TODAY()), SPLIT([Date], ","))?

What does that mean?

Sorry for the confusion.
What I meant to say that I am using table 2 as a form. One of the columns in that form is referencing table 1. That column is as an “enum” type.

That Expression works the same way as the other one I tried. When tested, it gives a “Y” next to the correct Meeting Topic, but when in I view it as a table view, nothing shows up.

I meant to say that in the table 2 form that has a column that references Table 1, it doesn’t show any results. This column is “enum” type.

Thanks for your help Steve!

1 Like

I think some screenshots might help. Please post screenshots of:

  1. The Type Detail section of the Enum column in table 2.

  2. The slice configuration.

  3. The configuration of the table view that uses the slice.

Does this help?

1 Like

Hmm… Nothing looks amiss. How about a screenshot of the table view in the app that doesn’t show what you want?

But here is what shows up in the Slice Expression Editor when I hit “Test”

This going to require a bit more digging, it appears. I recommend you engage support@appsheet.com directly, as they’ll be able to access your app directly, which will make troubleshooting a lot quicker.

Bummer. Alright. Thank you Steve!

1 Like

Out of curiosity, do you need to be using DateTime values in the Dates column? It might be easier to solve without the time values altogether. I mean, either way, this is probably a bug that needs fixing.

I tried without the dates, but I wanted to use the “Today()” expressions (or syntax? idk lol) and it outputted a time “12:00:00 AM” and in the expression tester, it wouldn’t match unless I also put the time in the column. Am I doing something wrong? Because from what I read, the “Today()” isn’t supposed to spit out a time. Thanks for your help!