Slice isn't show all values

I have an issue I have a slice that is filtering out data and when I run the test on the filter expression the correct values return true which is correct but when the view loads it only shows half of the correct data. I am using the contain expression which is looking at multiple values I have stored and like I said when I run the test all the correct ones show true but they just aren’t loading up in the view. Just looking for some direction on this.

thanks,

Could you share the expression you’re using? And screenshots of the table’s column list, the slice config, and the view that only shows some but not all of the rows?

Here is the Expression (I am logged in with the email from the table

Contains(Lookup(USEREMAIL(),“SetFilter”,“Email”,“Filter”),[Title])

Here is the table I am pulling from

image

My slice

Results from test



The app results

So kinda at a lost cuz the test shows multiple results returning but when I am in the app only one.

Thanks for the help.

You’re sure the view that only displays the one row is actually using the intended slice?

Is the view displayed inline/nested within a detail view that limits nested tables to only a single row?