Slice not seeing enum

I have an Enum column with 3 choices

Accepted

Pending

Declined

I have slices based on those choices

(I’ve tried multiple ways to make this work again)

[Estimate Status]=Accepted - with and without quotes

CONTAINS([Estimate Status], “Accepted”) - with and without quotes

I get zero results now.

Ultimately the goal is to separate them and count.
Thanks!

Please provide a screenshot of the slice configuration, being sure to include the row filter expression.

Here’s a version with a CONTAINS
Selection_559

1 Like

Here’s another shot

Selection_560

1 Like

Where are you seeing this unexpected result? Please post a screenshot of the emulator that demonstrates the problem, and includes the View and Table indicators.

image

Here you go…

Selection_563

Tried this as well, still nothing…
COUNT(SELECT(Estimates[Estimate Status], IN([Estimate Status], {“Pending”})))

Not sure why you use contains or in expression with this.

just simply

[Estimate Status]=“Accepted”

for slice conditions

2 Likes

I’ve done that as well, both with and without quotes, still nothing in return…

Sanity check time. Make a temporary new VC in the base table with the expression:

[Estimate Status] = “Accepted”

Test this from the expression assistant, what does it show?


Are you using any Security Filters for this table?


Where did you get that last screenshot from, I don’t recognize it?

1 Like

Thanks Marc.
I disconnected and reconnected the tables and now they are working.
And yes I went back to my original expression which is =“accepted”
I think it may be a connection issue on my end. I work remotely, I mean I’m actually in the desert camping while working on these apps. I’ve seen a performance difference between browser’s during this as well.
Anyway, most likely the problem is on my end.
Thanks for reaching out.

1 Like