Slice view not allowing for edits

I am very new to creating in AppSheets and I created a slice view and selected in Update Mode: Updates, Adds, Deletes. In the app the data displays as read only. Any solutions please?

Hi @TerriKCC!

Welcome to the community!

There are at least two settings that affect whether or not a column in a table can be edited:

  1. The table setting

  1. The column setting

Screen Shot 2020-02-21 at 12.20.17

Each individual column that you want to edit must be set to “Editable”.

If these settings are OK, the there may be “view” settings that need to be adjusted.

1 Like

Typically, values may only be edited from a form view. Are you viewing you data from a form view?

Thank you for your response!

Yes I believe I am in the form view and do not see an option to edit. It appears to be strictly read-only.

I’ve tried to add an Action (Edit) but I am not allowed an option to select the slice.

Thank you for your welcome!

Unfortunately, all the settings match both your suggestions.
Not sure if it matters but the app is not deployed.
Any other suggestions?

This is a detail view, not a form view.

image

Scroll down until you see this icon and click on it:

image

Unfortunately there is no edit icon. I do see it in the other main tab - the one that is not a slice.

Does that mean I have to create both a slice and form view?

Does your table allow edits?

Yes! I made sure the data columns allowed for editing. No problems with adding, changing, and editing when in that view.

The slice is not configured to make the Edit action available:

image

Try adding it to the slice actions.

2 Likes

Thank you so much Steve - that was the ticket! It works now. Have a great weekend!

1 Like