SNAPSHOT() Error: null parameter

Hello,

To be honest this is my first time using SNAPSHOT(), but I have tried several different ways now and I keep getting the same error. I have tried with different views of the same app and I have also tried using LINKTOROW() and LINKTOVIEW() and I keep getting the same 2 Issues:

Issue 1: The saving time when using snapshot has been between 2 and 5 minutes (measured with a chronometer)

Issue 2: The image is being attached but it is always displaying the same error: - Parameter “parameter” contains null entry -

The image that is being attached to the emails is the next one:

Please contact Support for help with this.

https://www.appsheet.com/Support/Contact

2 Likes

I simply guess that you are using snapshot expression in somewhere in columm, either physical or virtuaul column instead of bot template ?
Then it is not going to work. You just see those errors.

@Steve

It is going to be fancy that snapthot expression is going to work with image type field, but it is not for the moment.

1 Like

I first used it in an e-mail body template and then in a pdf attachment template and neither way is working yet.

It should (or used to) work on PDF template.
Your expression used in template could be something wrong, but better to get contact with support, as it is possible because of a bug.

2 Likes