Spreadsheet updates not showing in app

Hey, I’m hoping to make weekly updates the one of my spreadsheets and have those updates reflected in the app. When I add new rows in google sheets I’m not seeing any updates even after syncing the app.

Any suggestions?

Is the option Delta Sync ON?

I did find the Delta Sync, turned it on and the 5 new rows on my google sheet are still not showing in the app.
The spreadsheet does not have external formulas.

Is it possible that you don’t have any value in your key column? Or maybe doubles?

I have one primary key, no doubles and no errors

Have you checked that the spreadsheet is the same?

Yes, the spreadsheets are the same.

When I open this table and click “view source”, the spreadsheet launches and I can see the new data I’ve added that has not been synced with the app.

I deleted the table in question and re-added it which allowed me to update the app from the spreadsheet one time.
I added another row and clicked sync and the app will not update any further.
It also would not remove the new row in the app when I deleted it in the spreadsheet.

It seems to me that AppSheets will play nice when data is appended but it stops syncing when rows are removed from the source data.
I’m almost certain that once I delete a row and try to sync thats what is throwing the app off.

Can you confirm if that’s by design or maybe a bug?

I’ve figured it out. Even though the google sheet saves automatically, you have to refresh the page and then sync the app.

You should not need to do that. If you change something on the gSheet, the sync should be enough.

I was working on my app 2 days ago without any issues and come back today and can’t get one of my tables to show the data in the gsheet

Gsheet:

Table in Appsheet:

The table columns look like this:

I have deleted the data from the gsheet and repasted it and refreshed the gsheet/the app and I can’t get this data to pull through anymore. Any ideas what might have caused this behavior?

In the app editor, in the Data >> Tables tab, for the Events table, re-select both the Source Path and Worksheet Name/Qualifier, even if they already look correct.

When re-selecting the Source Path, choose browse for more data and choose the spreadsheet file from the file picker, rather than simply choosing what’s already there.

image

2 Likes

Thanks for that suggestion, I did that and still have no luck. I also made a new tab in my gsheet and copied the data over and it is having the same issue on the data on the new tab. At the same time all of the other tabs are working for my other tabs in appsheet, so it seems like I have an issue in my Events table in appsheet that is causing the problem for some reason.

Probably best, then, to engage support@appsheet.com. Someone will probably have to look under the hood, so to speak.

1 Like

This week I ran into a similar problem. I am using the excel file. I added a new column and wanted to update the table.

Subsequently, I was getting an error saying I don’t have files or data / tables on Google Drive.

I checked out GDriver. My Excel File was in location.

Since the Google driver was synchronized on my computer, I opened my excel file on the computer and re-saved it. Excel file was uploaded to google driver and the problem was fixed.

I don’t know why your problem stems. But my advice is to back up your Excel or google spreadsheet file daily.

When I find time, I am thinking of writing a backup script with GAS for daily backup.

2 Likes

Thanks for the advice and glad you were able to get yours working. Ya the weird part of Gsheet is that it is always saving and live so there is no way for me to refresh it really. We will see what support can find out. Appreciate the help and advice.

2 Likes